agl-compositor_git: Enable loading waltham-transmitter-plugin 99/25699/9
authorMarius Vlad <marius.vlad@collabora.com>
Mon, 30 Nov 2020 22:38:27 +0000 (00:38 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 22 Jan 2021 14:54:00 +0000 (14:54 +0000)
The build system is able to determine if it can build support for
loading the plug-in when waltham depedency is satified. We add
that based on AGL_FEATURES.

Bug-AGL: SPEC-3601

Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Change-Id: Id7279fddc12c78472ae22a480626106a00ea30db
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25699
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb

index ccf7b88..edd0ca8 100644 (file)
@@ -8,7 +8,8 @@ SECTION = "x11"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=fac6abe0003c4d142ff8fa1f18316df0"
 
-DEPENDS = "wayland wayland-protocols wayland-native weston"
+DEPENDS = "wayland wayland-protocols wayland-native weston \
+          ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "e1e8c07e202ffccc7b56f8f116a2ef1624028f91"
@@ -28,3 +29,4 @@ FILES_${PN} = " \
                ${datadir}/${PN}/protocols/agl-shell.xml \
                ${datadir}/${PN}/protocols/agl-shell-desktop.xml \
               "
+RDEPENDS_${PN} += " ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"