meta-app-framework: add agl-driver to pipewire group 00/27100/2
authorAshok Sidipotu <ashok.sidipotu@collabora.com>
Thu, 27 Jan 2022 09:32:48 +0000 (15:02 +0530)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sun, 30 Jan 2022 13:09:34 +0000 (13:09 +0000)
- Update agl-session recipe to add agl-driver to pipewire
  group
- Apps in the new framework can access pipewire services
  if agl-driver is a part of pipewire group.

Bug-AGL: SPEC-4210

Signed-off-by: Ashok Sidipotu <ashok.sidipotu@collabora.com>
Change-Id: Iba3856006b36c0182aaa0e36e8e98f85d9c49af3
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27100
Reviewed-by: Georgios Kiagiadakis <george.kiagiadakis@collabora.com>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

meta-app-framework/recipes-config/agl-session/agl-session_0.1.bb

index dc7b5be..ecad161 100644 (file)
@@ -15,10 +15,11 @@ USERADDEXTENSION = "useradd-staticids"
 GROUPADD_PARAM:${PN} = "\
        --system display ; \
        --system video ; \
+       --system pipewire ; \
        -g 1001 agl-driver ; \
 "
 USERADD_PARAM:${PN} = "\
-  -g 1001 -u 1001 -G video,display -o -d /home/agl-driver -m -K PASS_MAX_DAYS=-1 agl-driver ; \
+  -g 1001 -u 1001 -G video,display,pipewire -o -d /home/agl-driver -m -K PASS_MAX_DAYS=-1 agl-driver ; \
 "
 
 SYSTEMD_PACKAGES = "${PN}"