config: fix wireplumber config issues 99/27099/2
authorAshok Sidipotu <ashok.sidipotu@collabora.com>
Wed, 26 Jan 2022 14:16:38 +0000 (19:46 +0530)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sun, 30 Jan 2022 13:09:34 +0000 (13:09 +0000)
- AGL project not to take the wireplumber project upstream config
 files which are recently moved to /usr/share/wireplumber/.
- create-items.lua to be loaded with correct arguments.

Change-Id: I57200755d749e2222e90996cc034f66baca5568a
Signed-off-by: Ashok Sidipotu <ashok.sidipotu@collabora.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27099
Reviewed-by: Georgios Kiagiadakis <george.kiagiadakis@collabora.com>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-pipewire/recipes-multimedia/wireplumber/wireplumber-config-agl/policy.lua.d/10-default-policy.lua
meta-pipewire/recipes-multimedia/wireplumber/wireplumber_git.bb

index d20bf6a..e6170dd 100644 (file)
@@ -123,8 +123,8 @@ load_module("mixer-api")
 -- Create endpoints statically at startup
 load_script("static-endpoints.lua", policy_config.endpoints)
 
-  -- Create session items for nodes that appear in the graph
-  load_script("create-item.lua", default_policy.policy)
+-- Create session items for nodes that appear in the graph
+load_script("create-item.lua", policy_config.policy)
 
 -- Link nodes to each other to make media flow in the graph
 load_script("policy-node.lua", policy_config.policy)
index bb2380d..a08ebbb 100644 (file)
@@ -60,7 +60,7 @@ FILES:${PN} = "\
     ${bindir}/wpctl \
     ${bindir}/wpexec \
     ${libdir}/wireplumber-${WPAPI}/* \
-    ${datadir}/wireplumber/* \
+    ${datadir}/wireplumber/scripts/* \
     ${systemd_system_unitdir}/* \
 "
 RPROVIDES:${PN} += "virtual/pipewire-sessionmanager"
@@ -72,6 +72,11 @@ FILES:lib${PN}-${WPAPI} = "\
 
 FILES:${PN}-config += "\
     ${sysconfdir}/wireplumber/* \
+    ${datadir}/wireplumber/*conf \
+    ${datadir}/wireplumber/common/* \
+    ${datadir}/wireplumber/main.lua.d/* \
+    ${datadir}/wireplumber/bluetooth.lua.d/* \
+    ${datadir}/wireplumber/policy.lua.d/* \
 "
 CONFFILES:${PN}-config += "\
     ${sysconfdir}/wireplumber/* \