Add sublayer for new application framework components 45/26945/3
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 1 Dec 2021 14:16:36 +0000 (15:16 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 2 Dec 2021 16:56:47 +0000 (16:56 +0000)
Setup the layer and a scripts/run-yocto-check-layer.sh .

Bug-AGL: SPEC-4161
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Change-Id: I762773107ada7263b854b2f9ea54d1f11adf1487
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26945
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

meta-app-framework/conf/layer.conf [new file with mode: 0644]
meta-app-framework/scripts/run-yocto-check-layer.sh [new file with mode: 0755]

diff --git a/meta-app-framework/conf/layer.conf b/meta-app-framework/conf/layer.conf
new file mode 100644 (file)
index 0000000..b82d8a1
--- /dev/null
@@ -0,0 +1,16 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+       ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "meta-app-framework"
+BBFILE_PATTERN_meta-app-framework = "^${LAYERDIR}/"
+BBFILE_PRIORITY_meta-app-framework = "60"
+
+LAYERSERIES_COMPAT_meta-app-framework = "dunfell"
+LAYERDEPENDS_meta-app-framework = "core aglcore"
+
+#
+LICENSE_PATH += "${LAYERDIR}/licenses"
diff --git a/meta-app-framework/scripts/run-yocto-check-layer.sh b/meta-app-framework/scripts/run-yocto-check-layer.sh
new file mode 100755 (executable)
index 0000000..62377d3
--- /dev/null
@@ -0,0 +1,37 @@
+#!/bin/bash
+#set -x
+
+SCRIPTPATH="$( cd $(dirname $0) >/dev/null 2>&1 ; pwd -P )"
+echo $SCRIPTPATH
+AGLROOT="$SCRIPTPATH/../../.."
+POKYDIR="$AGLROOT/external/poky"
+TMPROOT=`mktemp -d`
+
+rm -rf ${TMPROOT}/testbuild-ycl || true
+mkdir -p ${TMPROOT}/testbuild-ycl
+cd ${TMPROOT}/testbuild-ycl
+
+source $POKYDIR/oe-init-build-env .
+
+cat << EOF >> conf/local.conf
+# just define defaults
+AGL_FEATURES ?= ""
+AGL_EXTRA_IMAGE_FSTYPES ?= ""
+
+# important settings imported from poky-agl.conf
+# we do not import 
+DISTRO_FEATURES:append = " systemd"
+DISTRO_FEATURES_BACKFILL_CONSIDERED:append = " sysvinit"
+VIRTUAL-RUNTIME_init_manager = "systemd"
+
+EOF
+
+
+yocto-check-layer \
+       --dependency \
+       $AGLROOT/meta-agl/meta-agl-core \
+       -- \
+       $AGLROOT/meta-agl/meta-app-framework
+
+
+[ $? = 0 ] && rm -rf ${TMPROOT}/testbuild-ycl