agl-compositor: Add DISTRO_FEATURE to enable compositor 44/23044/2
authorDaniel Stone <daniels@collabora.com>
Mon, 25 Nov 2019 19:25:52 +0000 (19:25 +0000)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 26 Nov 2019 17:52:24 +0000 (17:52 +0000)
When the 'agl-compositor' distro feature is enabled, the AGL compositor
will be enabled and start at boot instead of Weston.

Change-Id: Idcd0c401c3d2c332637ddde1cd83d1fe85c4ae2a
Signed-off-by: Daniel Stone <daniels@collabora.com>
meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
templates/feature/agl-compositor/50_local.conf.inc [new file with mode: 0644]
templates/feature/agl-compositor/README_feature_agl-compositor.md [new file with mode: 0644]

index 398cd1c..247aeee 100644 (file)
@@ -3,7 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 inherit agl-graphical
 
 
-WESTONSTART ??= "/usr/bin/weston ${WESTONARGS}"
+WESTONSTART ??= "${@bb.utils.contains("DISTRO_FEATURES", "agl-compositor", "/usr/bin/agl-compositor", "/usr/bin/weston",d)} ${WESTONARGS}"
 WESTONSTART_append = " ${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", " --log=${DISPLAY_XDG_RUNTIME_DIR}/weston.log", "",d)}"
 
 DROPIN_NAME = "weston-init"
diff --git a/templates/feature/agl-compositor/50_local.conf.inc b/templates/feature/agl-compositor/50_local.conf.inc
new file mode 100644 (file)
index 0000000..be749b7
--- /dev/null
@@ -0,0 +1 @@
+DISTRO_FEATURES_append = " agl-compositor"
diff --git a/templates/feature/agl-compositor/README_feature_agl-compositor.md b/templates/feature/agl-compositor/README_feature_agl-compositor.md
new file mode 100644 (file)
index 0000000..4b5211e
--- /dev/null
@@ -0,0 +1,13 @@
+---
+description: Feature agl-compositor
+authors: Daniel Stone <daniels@collabora.com>
+---
+       
+### Feature agl-compositor
+        
+_agl-compositor_ is a new Wayland display server framework, based on the
+existing libweston library. It provides AGL users an extensible framework for
+window/input/output management within the display server.
+
+It is included as a technology preview, and is not currently ready for
+production use.