Security: Adding the library xmlsec
[AGL/meta-agl.git] / meta-agl-security / recipes-core / xmlsec1 / xmlsec1_1.2.20.bb
1 inherit autotools pkgconfig
2
3 SUMMARY = "Library providing support for "XML Signature" and "XML Encryption" standards"
4 DESCRIPTION = "XML Security Library is a C library based on LibXML2  and OpenSSL. \ 
5 The library was created with a goal to support major XML security \
6 standards "XML Digital Signature" and "XML Encryption". \
7 "
8
9 HOMEPAGE = "https://www.aleksey.com/xmlsec"
10 LICENSE = "MIT"
11 LIC_FILES_CHKSUM = "file://Copyright;md5=32e47e213c77c55d2c666351d7ce16b5"
12
13 SRC_URI = "git://git.gnome.org/xmlsec;branch=master;protocol=git"
14 SRCREV = "84c8281cf927b1cdcc38f343f61c3aa448a5a10f"
15
16 SECTION = "base"
17
18 S = "${WORKDIR}/git"
19
20 RDEPENDS_${PN} = "openssl libxml2"
21
22 # choice is made to use openssl only and to not use xslt
23 # nss would be a valuable choice
24 EXTRA_OECONF = "\
25         --disable-crypto-dl \
26         --disable-apps-crypto-dl \
27         --enable-shared \
28         --disable-static \
29         --without-gnutls \
30         --without-gcrypt \
31         --without-nss \
32         --without-libxslt \
33 "
34
35 do_install_append() {
36         # discarding this optional file is good for AGL
37         rm ${D}${libdir}/xmlsec1Conf.sh
38 }
39
40