Security: Adding the library xmlsec 65/4265/2
authorJosé Bollo <jose.bollo@iot.bzh>
Mon, 2 Nov 2015 11:05:27 +0000 (12:05 +0100)
committerGerrit Code Review <gerrit@172.30.200.200>
Mon, 9 Nov 2015 16:50:25 +0000 (16:50 +0000)
XmlSec is a library used for signing, validating,
and crypting XML files according to XMLDSIG,
the recommendation of the W3C. See
http://www.w3.org/TR/xmldsig-core1

The library is integrated with use of openSSL
only and without XSLT library integration.

Change-Id: I685e3b476d936bcedb52dd88da9f4286182e0c58
Signed-off-by: José Bollo <jose.bollo@iot.bzh>
meta-agl-security/recipes-core/xmlsec1/xmlsec1_1.2.20.bb [new file with mode: 0644]

diff --git a/meta-agl-security/recipes-core/xmlsec1/xmlsec1_1.2.20.bb b/meta-agl-security/recipes-core/xmlsec1/xmlsec1_1.2.20.bb
new file mode 100644 (file)
index 0000000..7faf7bf
--- /dev/null
@@ -0,0 +1,40 @@
+inherit autotools pkgconfig
+
+SUMMARY = "Library providing support for "XML Signature" and "XML Encryption" standards"
+DESCRIPTION = "XML Security Library is a C library based on LibXML2  and OpenSSL. \ 
+The library was created with a goal to support major XML security \
+standards "XML Digital Signature" and "XML Encryption". \
+"
+
+HOMEPAGE = "https://www.aleksey.com/xmlsec"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://Copyright;md5=32e47e213c77c55d2c666351d7ce16b5"
+
+SRC_URI = "git://git.gnome.org/xmlsec;branch=master;protocol=git"
+SRCREV = "84c8281cf927b1cdcc38f343f61c3aa448a5a10f"
+
+SECTION = "base"
+
+S = "${WORKDIR}/git"
+
+RDEPENDS_${PN} = "openssl libxml2"
+
+# choice is made to use openssl only and to not use xslt
+# nss would be a valuable choice
+EXTRA_OECONF = "\
+       --disable-crypto-dl \
+       --disable-apps-crypto-dl \
+       --enable-shared \
+       --disable-static \
+       --without-gnutls \
+       --without-gcrypt \
+       --without-nss \
+       --without-libxslt \
+"
+
+do_install_append() {
+       # discarding this optional file is good for AGL
+       rm ${D}${libdir}/xmlsec1Conf.sh
+}
+
+