html5-mixer: recover HTML5 mixer demo application. 69/27669/1
authorJose Dapena Paz <jdapena@igalia.com>
Tue, 31 May 2022 16:15:32 +0000 (18:15 +0200)
committerJose Dapena Paz <jdapena@igalia.com>
Thu, 16 Jun 2022 13:20:08 +0000 (15:20 +0200)
Add updated html5-mixer:
* Fixes build with new application framework  providing audiomixer mock.
* Updates NPM dependencies.
* Updates recipe for kirkstone.

Bug-AGL: SPEC-4248
Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
Change-Id: Ie0ac5edb0be83a26cf627b962472d7ac7208e1c5

recipes-demo/html5-mixer/files/webapps-mixer.desktop [new file with mode: 0644]
recipes-demo/html5-mixer/html5-mixer_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb

diff --git a/recipes-demo/html5-mixer/files/webapps-mixer.desktop b/recipes-demo/html5-mixer/files/webapps-mixer.desktop
new file mode 100644 (file)
index 0000000..eab7ca3
--- /dev/null
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Name=HTML5 Mixer
+Comment=Mixer
+GenericName=Mixer
+Exec=/usr/bin/WebAppMgr --appid=webapps-mixer --app-install-dir=/usr/lib/wam_apps/html5-mixer/
+Icon=settings
+Terminal=false
+Type=Application
+Categories=System;
+StartupNotify=true
diff --git a/recipes-demo/html5-mixer/html5-mixer_git.bb b/recipes-demo/html5-mixer/html5-mixer_git.bb
new file mode 100644 (file)
index 0000000..4a46e9b
--- /dev/null
@@ -0,0 +1,42 @@
+SUMMARY     = "AGL HTML5 mixer Application"
+HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-mixer/"
+SECTION     = "apps"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git"
+B       = "${WORKDIR}/build"
+
+SRC_URI = " \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-mixer;protocol=https;branch=master \
+  file://webapps-mixer.desktop \
+"
+SRCREV = "c189320ab6810d4c916fa8f697a9452f3a8976a4"
+
+inherit pythonnative
+
+DEPENDS = "nodejs-native"
+
+do_compile[network] = "1"
+do_compile() {
+  cd ${S}
+  rm -rf package node_modules package-lock.json
+  npm install
+  npm run build
+}
+
+WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+APPLICATIONS_DIR="${datadir}/applications"
+
+do_install() {
+  install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+  cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+  install -d ${D}${APPLICATIONS_DIR}
+  install ${WORKDIR}/webapps-mixer.desktop ${D}${APPLICATIONS_DIR}
+}
+
+FILES:${PN} = " \
+  ${WAM_APPLICATIONS_DIR}/${PN} \
+  ${APPLICATIONS_DIR} \
+"
index b66806c..a9fbca1 100644 (file)
@@ -35,6 +35,7 @@ AGL_APPS = " \
     html5-homescreen \
     html5-hvac \
     html5-mediaplayer \
+    html5-mixer \
     ondemandnavi \
     html5-settings \
     "