html5-mediaplayer: recover HTML5 mediaplayer demo application. 68/27668/1
authorJose Dapena Paz <jdapena@igalia.com>
Tue, 31 May 2022 15:17:32 +0000 (17:17 +0200)
committerJose Dapena Paz <jdapena@igalia.com>
Thu, 16 Jun 2022 13:20:08 +0000 (15:20 +0200)
Add updated html5-mediaplayer:
* Fixes build with new application framework  providing mediaplayer mock.
* Updates NPM dependencies.
* Updates recipe for kirkstone.

Bug-AGL: SPEC-4248
Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
Change-Id: Iabc5944771a0aa7ef09b0464c6c2602f0a31c9ec

recipes-demo/html5-mediaplayer/files/webapps-mediaplayer.desktop [new file with mode: 0644]
recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb

diff --git a/recipes-demo/html5-mediaplayer/files/webapps-mediaplayer.desktop b/recipes-demo/html5-mediaplayer/files/webapps-mediaplayer.desktop
new file mode 100644 (file)
index 0000000..4322d6c
--- /dev/null
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Name=HTML5 Media Player
+Comment=Media player
+GenericName=Media player
+Exec=/usr/bin/WebAppMgr --appid=webapps-mediaplayer --app-install-dir=/usr/lib/wam_apps/html5-mediaplayer/
+Icon=settings
+Terminal=false
+Type=Application
+Categories=System;
+StartupNotify=true
diff --git a/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb b/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb
new file mode 100644 (file)
index 0000000..4fd1df2
--- /dev/null
@@ -0,0 +1,42 @@
+SUMMARY     = "AGL HTML5 media player Application"
+HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-mediaplayer/"
+SECTION     = "apps"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git"
+B       = "${WORKDIR}/build"
+
+SRC_URI = " \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-mediaplayer;protocol=https;branch=master \
+  file://webapps-mediaplayer.desktop \
+"
+SRCREV = "07adebd03e37a790462f80b6f3bb001bad7e6748"
+
+inherit pythonnative
+
+DEPENDS = "nodejs-native"
+
+do_compile[network] = "1"
+do_compile() {
+  cd ${S}
+  rm -rf package node_modules package-lock.json
+  npm install
+  npm run build
+}
+
+WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+APPLICATIONS_DIR="${datadir}/applications"
+
+do_install() {
+  install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+  cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+  install -d ${D}${APPLICATIONS_DIR}
+  install ${WORKDIR}/webapps-mediaplayer.desktop ${D}${APPLICATIONS_DIR}
+}
+
+FILES:${PN} = " \
+  ${WAM_APPLICATIONS_DIR}/${PN} \
+  ${APPLICATIONS_DIR} \
+"
index d91c96e..b66806c 100644 (file)
@@ -34,6 +34,7 @@ AGL_APPS = " \
     html5-launcher \
     html5-homescreen \
     html5-hvac \
+    html5-mediaplayer \
     ondemandnavi \
     html5-settings \
     "