html5-launcher_git: Remove autobuild script builds 64/27264/1
authorMarius Vlad <marius.vlad@collabora.com>
Fri, 11 Mar 2022 15:32:27 +0000 (17:32 +0200)
committerMarius Vlad <marius.vlad@collabora.com>
Fri, 11 Mar 2022 15:35:03 +0000 (17:35 +0200)
Bug-AGL: SPEC-4295
Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Change-Id: Icd6b09cdf57b40be6c7ebd11c527036240f248eb

recipes-demo/html5-launcher/html5-launcher_git.bb

index 61899e4..5c70fd7 100644 (file)
@@ -17,9 +17,10 @@ SRCREV = "${AGL_APP_REVISION}"
 DEPENDS = "nodejs-native"
 
 do_compile() {
-  bldcmd=${S}/autobuild/agl/autobuild
   cd ${S}
-  $bldcmd build
+  rm -rf package node_modules package-lock.json
+  npm install
+  npm run build
 }
 
 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
@@ -38,4 +39,4 @@ FILES_${PN} = " \
 "
 
 RCONFLICTS_${PN} = "launcher"
-RDEPENDS_${PN} = "applaunchd"
\ No newline at end of file
+RDEPENDS_${PN} = "applaunchd"