HotFix: ces2017-demo build failure 29/7729/1
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Tue, 20 Dec 2016 14:44:38 +0000 (23:44 +0900)
committerNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Tue, 20 Dec 2016 14:44:38 +0000 (23:44 +0900)
Home-app was deleted from CES 2017-Demo but it has not been deleted from the recipe.
That is causing the situation that master can not build.
This patch will recover this problem.

Change-Id: I029132acc2e20dc8272de9276c4be09b14ae9f3b
Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
recipes-demo-hmi/CES2017-demo/CES2017-demo.bb

index cee903a..631cbc1 100644 (file)
@@ -57,22 +57,6 @@ do_install_prepend() {
 
 
 
-    echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
-<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"home\" version=\"0.1\"> \
-  <name>Home</name> \
-  <content src=\"home\" type=\"application/x-executable\"/> \
-  <description>Home app.</description> \
-  <author>Qt</author> \
-  <icon src=\"home.png\"/> \
-  <license>Apache 2.0</license> \
-</widget> \
-" > ${B}/apps/Home/config.xml
-
-    cd ${B}/apps/Home/
-    zip home.wgt config.xml home
-
-
-
     echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
 <widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"hvac\" version=\"0.1\"> \
   <name>HVAC</name> \
@@ -156,7 +140,6 @@ do_install_prepend() {
        #!/bin/sh
        /usr/bin/afm-util install controls.wgt
        /usr/bin/afm-util install dashboard.wgt
-       /usr/bin/afm-util install home.wgt
        /usr/bin/afm-util install hvac.wgt
        /usr/bin/afm-util install mediaplayer.wgt
        /usr/bin/afm-util install phone.wgt
@@ -169,7 +152,6 @@ do_install() {
     install -d ${D}/usr/AGL/${PN}
     install -m 0644 ${B}/apps/Controls/controls.wgt ${D}/usr/AGL/${PN}/
     install -m 0644 ${B}/apps/Dashboard/dashboard.wgt ${D}/usr/AGL/${PN}/
-    install -m 0644 ${B}/apps/Home/home.wgt ${D}/usr/AGL/${PN}/
     install -m 0644 ${B}/apps/HVAC/hvac.wgt ${D}/usr/AGL/${PN}/
     install -m 0644 ${B}/apps/MediaPlayer/mediaplayer.wgt ${D}/usr/AGL/${PN}/
     install -m 0644 ${B}/apps/Phone/phone.wgt ${D}/usr/AGL/${PN}/