Add navigation recipe for home screen adaptated 51/7651/2
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Thu, 15 Dec 2016 10:30:50 +0000 (19:30 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 19 Dec 2016 17:34:59 +0000 (17:34 +0000)
Navigation will be able to work with AGLDistro 3.0 by this patch.
This recipe refers to the staging version repository.

Change-Id: I4b8bb5f020a316194f049f06a6391d9457540de6
Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
recipes-demo-hmi/navigation/navigation/config.xml [new file with mode: 0755]
recipes-demo-hmi/navigation/navigation/flite.in [new file with mode: 0755]
recipes-demo-hmi/navigation/navigation/jtalk.in [new file with mode: 0755]
recipes-demo-hmi/navigation/navigation_git.bb [new file with mode: 0755]

diff --git a/recipes-demo-hmi/navigation/navigation/config.xml b/recipes-demo-hmi/navigation/navigation/config.xml
new file mode 100755 (executable)
index 0000000..954974d
--- /dev/null
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<widget xmlns="http://www.w3.org/ns/widgets" id="navigation" version="0.1">
+  <name>Navigation</name>
+  <icon src="navigation.png"/>
+  <content src="navi" type="application/x-executable"/>
+  <description>NAVIGATION App</description>
+  <author>AISIN AW</author>
+  <license>GPL</license>
+</widget>
diff --git a/recipes-demo-hmi/navigation/navigation/flite.in b/recipes-demo-hmi/navigation/navigation/flite.in
new file mode 100755 (executable)
index 0000000..fee0c1c
--- /dev/null
@@ -0,0 +1,6 @@
+#!/bin/sh
+TMP=/tmp/navi.wav
+echo "$1" | flite_hts_engine -m  @datadir@/Voice/us/cmu_us_arctic_slt.htsvoice -o $TMP
+paplay --property='media.name=Navi' $TMP
+rm -f $TMP
+
diff --git a/recipes-demo-hmi/navigation/navigation/jtalk.in b/recipes-demo-hmi/navigation/navigation/jtalk.in
new file mode 100755 (executable)
index 0000000..c0670f7
--- /dev/null
@@ -0,0 +1,6 @@
+#!/bin/sh
+TMP=/tmp/navi.wav
+echo "$1" | open_jtalk -ow $TMP -m @exec_prefix@/share/Voice/mei/mei_normal.htsvoice -x @exec_prefix@/share/dic/
+paplay --property='media.name=Navi' $TMP
+rm -f $TMP
+
diff --git a/recipes-demo-hmi/navigation/navigation_git.bb b/recipes-demo-hmi/navigation/navigation_git.bb
new file mode 100755 (executable)
index 0000000..89bf4d0
--- /dev/null
@@ -0,0 +1,44 @@
+LICENSE="GPLv2"
+LIC_FILES_CHKSUM="file://LICENSE;md5=3595e9c703a847d990664d2b396a9df0 \
+                  file://COPYING;md5=947b2d60ca3872e172034438e9801200"
+
+DEPENDS = " \
+          glib-2.0 freetype sqlite3 wayland zlib expat openssl virtual/libgles2 virtual/libgl virtual/egl \
+          wayland \
+          "
+
+RDEPENDS_${PN} = " flite openjtalk "
+
+SRCREV="153f9d7ecb652732b1acc1cb00919c6a6af5556e"
+SRC_URI="git://github.com/AGLExport/gpsnavi.git \
+         file://flite.in \
+         file://jtalk.in \
+         file://config.xml \
+"
+
+# To avoid C++ library link failure
+SECURITY_CFLAGS = ""
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/git"
+
+do_compile_prepend() {
+   cp ${WORKDIR}/flite.in ${S}/
+   cp ${WORKDIR}/jtalk.in ${S}/
+}
+
+do_install_append() {
+   mkdir -p ${WORKDIR}/widget
+   install -m 0644 ${WORKDIR}/config.xml ${WORKDIR}/widget
+   install -m 0755 ${D}/usr/bin/navi ${WORKDIR}/widget
+   zip -ju ${WORKDIR}/widget/navigation.wgt ${WORKDIR}/widget/navi ${WORKDIR}/widget/config.xml
+
+   install -d ${D}/usr/AGL/ces2017-demo
+   install -m 0644 ${WORKDIR}/widget/navigation.wgt ${D}/usr/AGL/ces2017-demo/
+   install -d ${D}/usr/AGL/ces2017-demo
+
+   install -d ${D}/usr/share/mapdata
+}
+
+FILES_${PN} += " /usr/AGL/ces2017-demo/navigation.wgt /usr/share/mapdata "