Fix rpm metadata issue between cmake and nativesdk-qtbase 01/10901/5
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Thu, 14 Sep 2017 17:12:26 +0000 (19:12 +0200)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Thu, 14 Sep 2017 17:50:04 +0000 (19:50 +0200)
  file /opt/poky-agl/4.90.0+snapshot/sysroots/x86_64-aglsdk-linux/environment-setup.d conflicts between attempted installs of nativesdk-cmake-3.7.2-r0.x86_64_nativesdk and nativesdk-qtbase-tools-5.8.0+git0+49dc9aa409-r0.x86_64_nativesdk

Reference: https://stackoverflow.com/questions/45716949/during-sdk-build-environment-setup-d-conflicts-between-attempted-installs

Bug-AGL: SPEC-888

Change-Id: Iba6dd819cec44da26744a35eee31da968c9eb6ce
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-qt/qt5/qtbase_%.bbappend

index af2722d..2deed9a 100644 (file)
@@ -16,3 +16,7 @@ PACKAGECONFIG[wayland]="-qpa wayland-egl -no-qpa-platform-guard"
 
 # Temporarily fix bug due to binutils 2.28
 QT_CONFIG_FLAGS_append = " -no-use-gold-linker"
+
+# hotfix for RPM folder clash 
+#   file /opt/poky-agl/4.90.0+snapshot/sysroots/x86_64-aglsdk-linux/environment-setup.d conflicts between attempted installs of nativesdk-cmake-3.7.2-r0.x86_64_nativesdk and nativesdk-qtbase-tools-5.8.0+git0+49dc9aa409-r0.x86_64_nativesdk
+DIRFILES_class-nativesdk = ""
\ No newline at end of file