Fix rpm metadata issue between cmake and nativesdk-qtbase
[AGL/meta-agl-demo.git] / recipes-qt / qt5 / qtbase_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3 DEPENDS_append_koelsch = " libegl"
4 DEPENDS_append_porter = " libegl"
5
6 PACKAGECONFIG_WAYLAND = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
7 PACKAGECONFIG_GL = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2', '', d)}"
8 PACKAGECONFIG_append = " ${PACKAGECONFIG_WAYLAND} icu accessibility"
9 PACKAGECONFIG_append = " fontconfig"
10 PACKAGECONFIG_append = " sql-sqlite"
11
12 EXTRA_OECONF_append = ""
13
14 # '-qpa wayland-egl' set wayland-egl as default of platform plagins
15 PACKAGECONFIG[wayland]="-qpa wayland-egl -no-qpa-platform-guard"
16
17 # Temporarily fix bug due to binutils 2.28
18 QT_CONFIG_FLAGS_append = " -no-use-gold-linker"
19
20 # hotfix for RPM folder clash 
21 #   file /opt/poky-agl/4.90.0+snapshot/sysroots/x86_64-aglsdk-linux/environment-setup.d conflicts between attempted installs of nativesdk-cmake-3.7.2-r0.x86_64_nativesdk and nativesdk-qtbase-tools-5.8.0+git0+49dc9aa409-r0.x86_64_nativesdk
22 DIRFILES_class-nativesdk = ""