Restore chromium target and browser service 17/26317/5 11.91.0 lamprey/11.91.0 lamprey_11.91.0
authorRoger Zanoni <rzanoni@igalia.com>
Wed, 7 Apr 2021 15:01:14 +0000 (17:01 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 12 May 2021 08:54:16 +0000 (08:54 +0000)
- Merged chromium changes to fix build after bumping to chromium 84
- Fixed chromium install on current recipe
- Restored the chromium browser service

Bug-AGL: SPEC-3830
Signed-off-by: Roger Zanoni <rzanoni@igalia.com>
Change-Id: I5cde7972021a4200581c2e161f848bcf7d8d0458

recipes-platform/packagegroups/packagegroup-agl-appfw-html5.bb
recipes-wam/chromium/chromium-browser-service.bb [new file with mode: 0644]
recipes-wam/chromium/chromium.inc
recipes-wam/chromium/chromium84_git.bb

index a857a15..cc9ed3d 100644 (file)
@@ -13,5 +13,6 @@ ALLOW_EMPTY_${PN} = "1"
 
 # add packages for WAM
 RDEPENDS_${PN} += " \
+    chromium-browser-service \
     wam \
     "
diff --git a/recipes-wam/chromium/chromium-browser-service.bb b/recipes-wam/chromium/chromium-browser-service.bb
new file mode 100644 (file)
index 0000000..58177ce
--- /dev/null
@@ -0,0 +1,19 @@
+SUMMARY = "Chromium browser widget"
+DESCRIPTION = "Wgt packaging for running chromium installed browser"
+HOMEPAGE = "https://webosose.org"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/chromium;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+#build-time dependencies
+DEPENDS += "af-binder af-main-native chromium84"
+
+inherit cmake aglwgt
+
+RDEPENDS_${PN} += "chromium84-browser"
index 31542d1..69c9b43 100644 (file)
@@ -39,7 +39,7 @@ BROWSER_APP_BUILD_TARGET = "chrome"
 BROWSER_APPLICATION = "chromium84-browser"
 BROWSER_APPLICATION_DIR = "/opt/chromium84"
 
-TARGET = "${WEBRUNTIME_BUILD_TARGET}"
+TARGET = "${WEBRUNTIME_BUILD_TARGET} ${BROWSER_APP_BUILD_TARGET}"
 
 # Skip do_install_append of webos_system_bus. It is not compatible with this component.
 WEBOS_SYSTEM_BUS_FILES_LOCATION = "${S}/files/sysbus"
@@ -76,7 +76,8 @@ GN_ARGS = "\
     treat_warnings_as_errors=false\
     is_agl=true\
     use_cbe=true\
-    is_chrome_cbe=false\
+    is_chrome_cbe=true\
+    is_component_build=false\
     use_cups=false\
     use_custom_libcxx=false\
     use_kerberos=false\
@@ -239,16 +240,15 @@ configure_browser_settings() {
 }
 
 install_chromium_browser() {
+    # Install browser files
+    ${S}/depot_tools/ninja ${PARALLEL_MAKE} -C ${OUT_DIR}/${BUILD_TYPE} webos/install/default_browser
+
     D_DIR=${D}${BROWSER_APPLICATION_DIR}
+    L_DIR=${D}${CBE_DATA_PATH}
     install -d ${D_DIR}
+    install -d ${L_DIR}
 
-    # Install browser files
-     if [ -e "${SRC_DIR}/webos/install" ]; then
-         cd ${OUT_DIR}/${BUILD_TYPE}
-         xargs --arg-file=${SRC_DIR}/webos/install/default_browser/binary.list cp -R --no-dereference --preserve=mode,links -v --target-directory=${D_DIR}
-         cd ${SRC_DIR}
-         xargs --arg-file=${SRC_DIR}/webos/install/default_browser/runtime.list cp -R --no-dereference --preserve=mode,links -v --target-directory=${D_DIR}
-     fi
+    cp -R --no-dereference --preserve=mode,links -v ${OUT_IMAGE_DIR}/${BROWSER_APPLICATION_DIR}/* ${D_DIR}
 
     # AGL does not have PMLOG
     sed -i.bak s/PmLogCtl.*// ${D_DIR}/run_webbrowser
@@ -310,6 +310,7 @@ install_webruntime() {
 
 do_install() {
     install_webruntime
+    install_chromium_browser
 }
 
 WEBOS_SYSTEM_BUS_DIRS_LEGACY_BROWSER_APPLICATION = " \
index f5d0732..7acc2f8 100644 (file)
@@ -8,9 +8,9 @@ SRC_URI = "\
 "
 
 # Needed by catapult
-DEPENDS += "python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
+DEPENDS += "libhomescreen python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
 
-SRCREV_chromium84 = "20b9dd7995c70950e45d66c7c8cc2b2487c90eb6"
+SRCREV_chromium84 = "26c9a59becc7c81ec69f23673e0d45e7e2372b1d"
 SRCREV_v8 = "5c1d89dd2945a10cf7a6a3458050b3177a870b09"
 
 BROWSER_APPLICATION = "chromium84-browser"