Restore chromium target and browser service
[AGL/meta-agl-demo.git] / recipes-wam / chromium / chromium84_git.bb
1 require chromium.inc
2
3 SRC_URI = "\
4     git://github.com/igalia/${PN};branch=koi;protocol=https;rev=${SRCREV_chromium84};name=chromium84 \
5     git://github.com/webosose/chromium-v8;branch=@chromium84;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8 \
6     file://chromium-quiche-invalid-offsetof.patch \
7     file://chromium-skia-no_sanitize.patch \
8 "
9
10 # Needed by catapult
11 DEPENDS += "libhomescreen python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
12
13 SRCREV_chromium84 = "26c9a59becc7c81ec69f23673e0d45e7e2372b1d"
14 SRCREV_v8 = "5c1d89dd2945a10cf7a6a3458050b3177a870b09"
15
16 BROWSER_APPLICATION = "chromium84-browser"
17 BROWSER_APPLICATION_DIR = "/opt/chromium84"
18 MKSNAPSHOT_PATH = "v8_snapshot/"
19
20 PACKAGECONFIG_remove="jumbo"
21
22 GN_ARGS += "use_gtk=false"
23
24 # Disable closure_compile
25 # Else we need HOSTTOOLS += "java"
26 GN_ARGS += "closure_compile=false"
27
28 # When using meta-clang, one can switch to using the lld linker
29 # by using the ld-is-lld distro feature otherwise use gold linker
30 GN_ARGS += "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', 'use_lld=true use_gold=false', bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', 'use_lld=false use_gold=true', 'use_lld=false use_gold=false', d), d)}"
31
32 # Toolchains we will use for the build. We need to point to the toolchain file
33 # we've created, set the right target architecture and make sure we are not
34 # using Chromium's toolchain (bundled clang, bundled binutils etc).
35 GN_ARGS += "\
36     host_toolchain=\"//build/toolchain/cros:host\" \
37     cros_host_is_clang=false \
38     use_custom_libcxx_for_host=false \
39     cros_host_ar=\"${BUILD_AR}\" \
40     cros_host_cc=\"${BUILD_CC} ${BUILD_CFLAGS}\" \
41     cros_host_cxx=\"${BUILD_CXX} ${BUILD_CXXFLAGS}\" \
42     cros_host_extra_ldflags=\"${BUILD_LDFLAGS}\" \
43     custom_toolchain=\"//build/toolchain/cros:target\" \
44     is_clang=false \
45     use_custom_libcxx=false \
46     target_cpu=\"${@gn_arch_name('${TUNE_ARCH}')}\" \
47     cros_target_ar=\"${AR}\" \
48     cros_target_cc=\"${CC}\" \
49     cros_target_cxx=\"${CXX}\" \
50     cros_target_extra_ldflags=\"${LDFLAGS}\" \
51     v8_snapshot_toolchain=\"//build/toolchain/cros:v8_snapshot\" \
52     cros_v8_snapshot_is_clang=false \
53     cros_v8_snapshot_ar=\"${BUILD_AR}\" \
54     cros_v8_snapshot_cc=\"${BUILD_CC}\" \
55     cros_v8_snapshot_cxx=\"${BUILD_CXX}\" \
56     linux_use_bundled_binutils=false \
57     gold_path=\"\" \
58     v8_enable_embedded_builtins=false \
59     use_v8_context_snapshot=false \
60 "
61
62 GN_ARGS_append = " \
63   use_system_minigbm=false \
64   use_wayland_gbm=false \
65 "
66
67 GN_ARGS_append = " \
68   is_webos=false \
69   is_agl=true \
70 "
71
72 # TODO: drop this after we migrate to ubuntu 16.04 or above
73 GN_ARGS += "\
74     fatal_linker_warnings=false\
75 "
76
77 # TODO(rzanoni) copied from original recipe to fix qemux86 build.
78 # check if it can be removed in the future.
79 PACKAGECONFIG_remove_qemux86 = "gstreamer umediaserver neva-media gav neva-webrtc"
80 #END TODO