Initial Commit : AGL world wide navigation app 63/19363/3
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Wed, 26 Dec 2018 10:58:43 +0000 (19:58 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 13 Feb 2019 13:57:01 +0000 (13:57 +0000)
Navigation EG developed a new OSS navigation as the last activity.
This commit is the first commit of new OSS navi app.
This navigation application can navigate around the world.

Change-Id: I33eebc680f46786e941628a64695dccdcbf0f960
Signed-off-by: chenwei <i37546_Chin@aisin-aw.co.jp>
Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
recipes-demo-hmi/navigation/ondemandnavi/org.agl.naviapi.conf [new file with mode: 0755]
recipes-demo-hmi/navigation/ondemandnavi_git.bb [new file with mode: 0755]

diff --git a/recipes-demo-hmi/navigation/ondemandnavi/org.agl.naviapi.conf b/recipes-demo-hmi/navigation/ondemandnavi/org.agl.naviapi.conf
new file mode 100755 (executable)
index 0000000..7f4d85f
--- /dev/null
@@ -0,0 +1,15 @@
+<!DOCTYPE busconfig PUBLIC
+"-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
+"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
+<busconfig>
+       <policy context="default">
+               <!-- Allow everyone to talk to main service. We'll later add an agent to
+                    only share the location if user allows it. -->
+               <allow send_interface="org.agl.naviapi"/>
+       </policy>
+
+       <policy user="root">
+               <!-- Allow root to own the name on the bus -->
+               <allow own="org.agl.naviapi"/>
+       </policy>
+</busconfig>
diff --git a/recipes-demo-hmi/navigation/ondemandnavi_git.bb b/recipes-demo-hmi/navigation/ondemandnavi_git.bb
new file mode 100755 (executable)
index 0000000..52fee09
--- /dev/null
@@ -0,0 +1,36 @@
+SUMMARY     = "AGL Reference On Demand Navigation application."
+DESCRIPTION = "This application provides the function of Navigation to AGL. "
+HOMEPAGE    = "https://github.com/YoshitoMomiyama/aglqtnavigation.git"
+SECTION     = "apps"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+inherit qmake5 aglwgt pkgconfig
+
+SRC_URI = "git://github.com/YoshitoMomiyama/aglqtnavigation.git;branch=master \
+           file://org.agl.naviapi.conf \
+           "
+SRCREV  = "a6930c2dff988e45e18f91a2368d829c08942b30"
+
+DEPENDS += " qtbase qtquickcontrols2 \
+             qlibhomescreen \
+             qlibwindowmanager \
+             qtlocation qtaglextras \
+           "
+
+RDEPENDS_${PN} += " qtlocation \
+                    flite openjtalk \
+                  "
+
+RPROVIDES_${PN} = "virtual/navigation"
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+   install -d ${D}/etc/dbus-1/session.d/
+   install -m 0644 ${WORKDIR}/org.agl.naviapi.conf ${D}/etc/dbus-1/session.d/
+}
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+