phone: Replace QtMultimedia usage with 4A + gstreamer 29/19729/2
authorScott Murray <scott.murray@konsulko.com>
Thu, 17 Jan 2019 01:21:22 +0000 (20:21 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 11 Feb 2019 14:09:19 +0000 (14:09 +0000)
Update dependencies to remove qtmultimedia and add gstreamer.

Bug-AGL: SPEC-1596

Change-Id: Ifbaf65aeb5616897ba2f5f7b73aa397b39ef4231
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/phone/phone_git.bb

index d2997cd..553cc8a 100644 (file)
@@ -14,12 +14,12 @@ S  = "${WORKDIR}/git"
 
 # build-time dependencies
 DEPENDS += "qtquickcontrols2 \
-            qtmultimedia \
             libqtappfw \
             libhomescreen \
             qlibwindowmanager \
+            gstreamer1.0 \
 "
 
 inherit qmake5 aglwgt
 
-RDEPENDS_${PN} += "agl-service-telephony agl-service-bluetooth-pbap qtmultimedia"
+RDEPENDS_${PN} += "agl-service-telephony agl-service-bluetooth-pbap"