Add nativesdk-wayland to the SDK 51/11251/2
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Thu, 12 Oct 2017 15:42:02 +0000 (17:42 +0200)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Thu, 12 Oct 2017 22:46:20 +0000 (00:46 +0200)
To ensure we have all native tools available in the SDK

It should help to solve the missing tool issue in
https://gerrit.automotivelinux.org/gerrit/#/c/11083/ .

Use of TOOLCHAIN_HOST_TASK directly instead of bouncing through packagegroup.

Change-Id: I7e93e93c8601fb57e0d0a52ef7a2f091e0d12863
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-platform/images/agl-demo-platform-crosssdk.bb

index 6df9521..795ecc0 100644 (file)
@@ -44,3 +44,8 @@ TOOLCHAIN_TARGET_TASK += " \
     ffmpeg-dev \
     "
 
+# Add wayland-scanner to SDK (SPEC-945)
+# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
+# wayland-scanner is in nativesdk-wayland-dev !
+# option: add also nativesdk-qtwayland-tools
+TOOLCHAIN_HOST_TASK_append = " nativesdk-wayland nativesdk-wayland-dev"