Add switch between homescreen and homescreen-2017 49/11249/2
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Thu, 12 Oct 2017 14:58:07 +0000 (16:58 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 12 Oct 2017 21:55:18 +0000 (21:55 +0000)
Add option to switch between homescreen implementations.

Default is the 'old' homescreen.
Only if

  DISTRO_FEATURES += " agl-hmi-framework "

is set we switch to use the new packagegroup(s)
for homescreen-2017. This setting is done when you call
aglsetup.sh with the 'agl-hmi-framework' feature enabled.

Change-Id: Ieb45c1534f0759e8adb891f77ae85cb917e736e2
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-platform/packagegroups/packagegroup-agl-demo.bb

index dd397fc..cc93dda 100644 (file)
@@ -14,9 +14,14 @@ ALLOW_EMPTY_${PN} = "1"
 SMARTDEVICELINK = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-sdl', \
     'packagegroup-agl-smartdevicelink', '', d)}"
 
+# old homescreen package
+HOMESCREEN-OLD = "homescreen"
+# packages from hmi-framework aka homescreen-2017
+HOMESCREEN-NEW = "packagegroup-hmi-framework packagegroup-hmi-framework-dev"
+
 RDEPENDS_${PN} += "\
     packagegroup-agl-appfw \
-    homescreen \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-hmi-framework', '${HOMESCREEN-NEW}', '${HOMESCREEN-OLD}', d)} \
     udisks \
     ${SMARTDEVICELINK} \
     "