hvac: update recipe 63/27663/1
authorScott Murray <scott.murray@konsulko.com>
Thu, 16 Jun 2022 04:53:55 +0000 (00:53 -0400)
committerScott Murray <scott.murray@konsulko.com>
Thu, 16 Jun 2022 04:53:55 +0000 (00:53 -0400)
Update hvac app recipe to work with the new VehicleSignals API in
libqtappfw.  Like the updates previously done for other apps, this
means installing the new configuration file and associated JSON web
token file for KUKSA.val authorization.

Bug-AGL: SPEC-4409

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I3a21e381a315d3226d026a8d82aa1b82fc42ad7e

recipes-demo/hvac/hvac/hvac.conf [new file with mode: 0644]
recipes-demo/hvac/hvac/hvac.token [new file with mode: 0644]
recipes-demo/hvac/hvac_git.bb

diff --git a/recipes-demo/hvac/hvac/hvac.conf b/recipes-demo/hvac/hvac/hvac.conf
new file mode 100644 (file)
index 0000000..4a4bb71
--- /dev/null
@@ -0,0 +1,2 @@
+[vis-client]
+authorization = "/etc/xdg/AGL/hvac/hvac.token"
diff --git a/recipes-demo/hvac/hvac/hvac.token b/recipes-demo/hvac/hvac/hvac.token
new file mode 100644 (file)
index 0000000..770aadc
--- /dev/null
@@ -0,0 +1 @@
+eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.QQcVR0RuRJIoasPXYsMGZhdvhLjUalk4GcRaxhh3-0_j3CtVSZ0lTbv_Z3As5BfIYzaMlwUzFGvCVOq2MXVjRK81XOAZ6wIsyKOxva16zjbZryr2V_m3yZ4twI3CPEzJch11_qnhInirHltej-tGg6ySfLaTYeAkw4xYGwENMBBhN5t9odANpScZP_xx5bNfwdW1so6FkV1WhpKlCywoxk_vYZxo187d89bbiu-xOZUa5D-ycFkd1-1rjPXLGE_g5bc4jcQBvNBc-5FDbvt4aJlTQqjpdeppxhxn_gjkPGIAacYDI7szOLC-WYajTStbksUju1iQCyli11kPx0E66me_ZVwOX07f1lRF6D2brWm1LcMAHM3bQUK0LuyVwWPxld64uSAEsvSKsRyJERc7nZUgLf7COnUrrkxgIUNjukbdT2JVN_I-3l3b4YXg6JVD7Y5g0QYBKgXEFpZrDbBVhzo7PXPAhJD6-c3DcUQyRZExbrnFV56RwWuExphw8lYnbMvxPWImiVmB9nRVgFKD0TYaw1sidPSSlZt8Uw34VZzHWIZQAQY0BMjR33fefg42XQ1YzIwPmDx4GYXLl7HNIIVbsRsibKaJnf49mz2qnLC1K272zXSPljO11Ke1MNnsnKyUH7mcwEs9nhTsnMgEOx_TyMLRYo-VEHBDLuEOiBo
\ No newline at end of file
index ffa1234..2f3307c 100644 (file)
@@ -16,13 +16,29 @@ DEPENDS = " \
 
 PV = "2.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH} \
+           file://hvac.conf \
+           file://hvac.token \
+"
 SRCREV = "${AGL_APP_REVISION}"
 
 S = "${WORKDIR}/git"
 
 inherit qmake5 pkgconfig
 
+do_install:append() {
+    # Currently using default global client and CA certificates
+    # for KUKSA.val SSL, installing app specific ones would go here.
+
+    # VIS authorization token file for KUKSA.val should ideally not
+    # be readable by other users, but currently that's not doable
+    # until a packaging/sandboxing/MAC scheme is (re)implemented or
+    # something like OAuth is plumbed in as an alternative.
+    install -d ${D}${sysconfdir}/xdg/AGL/hvac
+    install -m 0644 ${WORKDIR}/hvac.conf ${D}${sysconfdir}/xdg/AGL/
+    install -m 0644 ${WORKDIR}/hvac.token ${D}${sysconfdir}/xdg/AGL/hvac/
+}
+
 FILES:${PN} += "${datadir}/icons/"
 
 RDEPENDS:${PN} += " \