demo-i2c-udev-conf: fix inclusion in packagegroup-agl-demo-platform 90/23590/3
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 6 Jan 2020 07:00:26 +0000 (08:00 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 6 Feb 2020 21:07:53 +0000 (21:07 +0000)
The inclusion was not working. Fix it.

Bug-AGL: SPEC-3091

.

Change-Id: Ibbeed9665e4f1cde58a7b60205b33f94a7039d59
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb

index 944b34b..d744f50 100644 (file)
@@ -62,11 +62,12 @@ CLUSTER_SUPPORT_PACKAGES = " \
 "
 CLUSTER_SUPPORT = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", "${CLUSTER_SUPPORT_PACKAGES}", "",d)}"
 
+DEMO_UNIT_CONF ?= ""
 # Hook for demo platform configuration
 # ATM used for:
 # 1) Adding udev configuration and scripts for supporting USB attached
 #    I2C devices for RTC and HVAC LED support.
-DEMO_PLATFORM_CONF = " demo-i2c-udev-conf "
+DEMO_UNIT_CONF += " demo-i2c-udev-conf "
 
 # Preload poi API key for demo if requested, and potentially maps for older
 # navigation application if it is configured.
@@ -74,7 +75,7 @@ DEMO_MAPS_LOCALE ?= "uk"
 DEMO_PRELOAD_MAPS = "${@bb.utils.contains("PREFERRED_RPROVIDER_virtual/navigation", "navigation", " navigation-maps-${DEMO_MAPS_LOCALE}", "",d)}"
 
 # Preload only if agl-demo-preload is set
-DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " ${DEMO_PRELOAD_MAPS} ${DEMO_PLATFORM_CONF} poiapp-api-key", "",d)}"
+DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " ${DEMO_PRELOAD_MAPS} ${DEMO_UNIT_CONF} poiapp-api-key", "",d)}"
 
 
 RDEPENDS_${PN}_append = " \