Update test/devel feature and crosssdk definitions 06/24506/3
authorScott Murray <scott.murray@konsulko.com>
Wed, 13 May 2020 01:03:23 +0000 (21:03 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 18 May 2020 10:29:55 +0000 (10:29 +0000)
To match the update in meta-agl, rework to drop the agl-test-wgt and
agl-devel-wgt feature package additions and now unnecessary test/devel
packagegroups. They'll now be pulled in by the COMPLEMENTARY_GLOBS
definitions for those image features.

As well, to ensure that agl-demo-platform-crosssdk contains required
extra additions, use new .inc file from meta-agl-profile-graphical-qt5
in the SDK definition.

Bug-AGL: SPEC-3300, SPEC-3375

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I6b54af5f7c76965171282ed81dc8160c69a9441f

conf/include/agl-demo.inc
recipes-platform/images/agl-demo-platform-crosssdk.bb [changed mode: 0755->0644]
recipes-platform/images/agl-demo-platform.inc
recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb

index 001f37d..32d447a 100644 (file)
@@ -6,14 +6,6 @@ DISTRO_FEATURES_append = " automount "
 
 IMAGE_INSTALL_append = " screen mc "
 
-# Add local packagegroups to agl-test-wgt and agl-devel-wgt image feature
-# package lists
-FEATURE_PACKAGES_agl-test-wgt_append = " packagegroup-agl-ivi-services-test"
-FEATURE_PACKAGES_agl-devel-wgt_append = " \
-    packagegroup-agl-ivi-services-devel \
-    packagegroup-agl-demo-platform-devel \
-    "
-
 # Extend agl-voiceagent-alexa image feature with local alexa-viewer
 # package.
 FEATURE_PACKAGES_agl-voiceagent-alexa_append = " alexa-viewer"
old mode 100755 (executable)
new mode 100644 (file)
index ed3bcb7..cd31551
@@ -8,8 +8,7 @@ require agl-demo-platform.bb
 
 LICENSE = "MIT"
 
-IMAGE_FEATURES_append = " dev-pkgs"
-IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
+require recipes-platform/images/agl-image-graphical-qt5-crosssdk.inc
 
 inherit populate_sdk populate_sdk_qt5
 
@@ -18,14 +17,6 @@ inherit populate_sdk populate_sdk_qt5
 # can failed (randomly).
 addtask do_populate_sdk after do_rootfs
 
-# Add wayland-scanner to SDK (SPEC-945)
-# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
-# wayland-scanner is in nativesdk-wayland-dev !
-# option: add also nativesdk-qtwayland-tools
-TOOLCHAIN_HOST_TASK_append = " nativesdk-wayland nativesdk-wayland-dev"
-
-TOOLCHAIN_HOST_TASK_append = " nativesdk-perl-modules "
-
 # Add mosquitto to support building the telematics demo application.
 # This is currently required for CI, as it uses agl-demo-platform-crosssdk
 # to build everything. An agenda item has been tabled for the May 2019 F2F
index 203fcc0..f363e30 100644 (file)
@@ -1,3 +1,2 @@
 # Base image
-require recipes-platform/images/agl-image-ivi.inc
-
+require agl-image-ivi.inc
index 1599299..9fde5ea 100644 (file)
@@ -3,11 +3,8 @@ LICENSE = "MIT"
 
 inherit packagegroup
 
-PROVIDES = "${PACKAGES}"
 PACKAGES = "\
     packagegroup-agl-ivi-services \
-    packagegroup-agl-ivi-services-test \
-    packagegroup-agl-ivi-services-devel \
     "
 
 RDEPENDS_${PN} += "\
@@ -32,12 +29,3 @@ RDEPENDS_${PN} += "\
     agl-service-weather \
     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'agl-service-taskmanager', '', d)} \
     "
-
-RDEPENDS_${PN}-test = "\
-    ${@' '.join([x + '-test' for x in str.split(d.getVar('RDEPENDS_${PN}'))])} \
-    "
-
-RDEPENDS_${PN}-devel = "\
-    ${@' '.join([x + '-dbg' for x in str.split(d.getVar('RDEPENDS_${PN}'))])} \
-    ${@' '.join([x + '-coverage' for x in str.split(d.getVar('RDEPENDS_${PN}'))])} \
-    "