Add azure-iot-sdk-c-dev to crosssdk 12/24512/1
authormaratsabitov <marat.sabitov@mera.com>
Wed, 13 May 2020 15:29:14 +0000 (18:29 +0300)
committermaratsabitov <marat.sabitov@mera.com>
Wed, 13 May 2020 15:29:14 +0000 (18:29 +0300)
Add azure-iot-sdk-c to support building agl-service-cloudproxy

Bug-AGL: SPEC-3376

Signed-off-by: maratsabitov <marat.sabitov@mera.com>
Change-Id: I895fc149243d90c58d81d318eecbf030bfbafc53

recipes-platform/images/agl-demo-platform-crosssdk.bb
templates/feature/agl-demo/50_bblayers.conf.inc

index 5bb0dc0..ed3bcb7 100755 (executable)
@@ -48,3 +48,7 @@ TOOLCHAIN_TARGET_TASK += "libstdc++-staticdev"
 # AddressSanitizer support to detect use-after-frees along with other
 # memory issue.
 TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
+
+# Add azure-iot-sdk-c to support building agl-service-cloudproxy and
+# other users of Azure sdk.
+TOOLCHAIN_TARGET_TASK += "azure-iot-sdk-c"
index 7e85c57..afa14f2 100644 (file)
@@ -3,3 +3,9 @@
 BBLAYERS =+ " \
    ${METADIR}/meta-agl-demo \
 "
+
+# OpenEmbedded layer to add support for multiple cloud service provider solutions
+#---------------------------------------------------
+BBLAYERS =+ " \
+   ${METADIR}/external/meta-iot-cloud \
+"