flutter-dashboard: update SRCREV 31/29231/2
authorScott Murray <scott.murray@konsulko.com>
Tue, 19 Sep 2023 12:02:08 +0000 (08:02 -0400)
committerScott Murray <scott.murray@konsulko.com>
Wed, 20 Sep 2023 17:06:46 +0000 (17:06 +0000)
Update flutter-dashboard SRCREV to pick up KUKSA.val databroker gRPC
API changes, update its YAML configuration file to match, and add the
JWT authorization token the configuration requires.

Bug-AGL: SPEC-4762

Change-Id: I8a2e2da5bf5a03c9e935b91b9b25c1aa0610c399
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29231
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

recipes-demo/flutter-dashboard/files/dashboard.token [new file with mode: 0644]
recipes-demo/flutter-dashboard/files/dashboard.yaml [new file with mode: 0644]
recipes-demo/flutter-dashboard/files/dashboard_config.yaml [deleted file]
recipes-demo/flutter-dashboard/flutter-dashboard_git.bb

diff --git a/recipes-demo/flutter-dashboard/files/dashboard.token b/recipes-demo/flutter-dashboard/files/dashboard.token
new file mode 100644 (file)
index 0000000..10fafb5
--- /dev/null
@@ -0,0 +1 @@
+eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJsb2NhbCBkZXYiLCJpc3MiOiJjcmVhdGVUb2tlbi5weSIsImF1ZCI6WyJrdWtzYS52YWwiXSwiaWF0IjoxNTE2MjM5MDIyLCJleHAiOjE3NjcyMjU1OTksInNjb3BlIjoicmVhZCJ9.P6tJPRSJWB51UOFDFs8qQ-lGqb1NoWgCekHUKyMiYcs8sR3FGVKSRjSkcqv1tXOlILvqhUwyuTKui25_kFKkTPv47GI0xAqcXtaTmDwHAWZHFC6HWGWGXohu7XvURrim5kMRVHy_VGlzasGgVap0JFk3wmaY-nyFYL_PLDjvGjIQuOwFiUtKK1PfiKviZKyc5EzPUEAoHxFL_BSOsTdDDcaydFe9rSKJzpYrj7qXY0hMJCje2BUGlSUIttR95aSjOZflSxiGystWHME8fKMmDERAx749Jpt37M3taCxBsUzER5olPz65MGzFSikfC-jH_KGmJ4zNYS65_OM1a-CPfW7Ts__pyAXxFULNMHRMIfh8Wiig4UcooMy_ZJO_DN2rq95XdaBbzRua5mxvO2wM6iu5kv4lhNxhjVNGuWFRLLJ_icBUZlvAuC3eqp66B-Y3jJNI0cSnIvsVX8YFVS3ebW8tf40OdeVou8fWZPcQsFAAafBhIxNOW8FbLZ9sRvQ-FGwZy-GyF52IJ5ZKeGfAkeEh9ZLIcyJ2YlGp4q0EOKIdwIBsWfCFtZbAvi2ornO3XvJm94NBqprpvQYN_IB7yyRxDduLjNKqqcFqnrlWYI-ZhvghWH2rEblplgHZdyVD1G9Mbv0_zdNTKFs6J7IP96aV6-4hBOt3kROlS1G7ObA
\ No newline at end of file
diff --git a/recipes-demo/flutter-dashboard/files/dashboard.yaml b/recipes-demo/flutter-dashboard/files/dashboard.yaml
new file mode 100644 (file)
index 0000000..e54c469
--- /dev/null
@@ -0,0 +1,2 @@
+authorization : "/etc/xdg/AGL/dashboard/dashboard.token"
+use-tls : true
diff --git a/recipes-demo/flutter-dashboard/files/dashboard_config.yaml b/recipes-demo/flutter-dashboard/files/dashboard_config.yaml
deleted file mode 100644 (file)
index 6824c6b..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-hostname : localhost
-port : 8090
-kuskaAuthToken : eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJtb2RpZnlUcmVlIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.p2cnFGH16QoQ14l6ljPVKggFXZKmD-vrw8G6Vs6DvAokjsUG8FHh-F53cMsE-GDjyZH_1_CrlDCnbGlqjsFbgAylqA7IAJWp9_N6dL5p8DHZTwlZ4IV8L1CtCALs7XVqvcQKHCCzB63Y8PgVDCAqpQSRb79JPVD4pZwkBKpOknfEY5y9wfbswZiRKdgz7o61_oFnd-yywpse-23HD6v0htThVF1SuGL1PuvGJ8p334nt9bpkZO3gaTh1xVD_uJMwHzbuBCF33_f-I5QMZO6bVooXqGfe1zvl3nDrPEjq1aPulvtP8RgREYEqE6b2hB8jouTiC_WpE3qrdMw9sfWGFbm04qC-2Zjoa1yYSXoxmYd0SnliSYHAad9aXoEmFENezQV-of7sc-NX1-2nAXRAEhaqh0IRuJwB4_sG7SvQmnanwkz-sBYxKqkoFpOsZ6hblgPDOPYY2NAsZlYkjvAL2mpiInrsmY_GzGsfwPeAx31iozImX75rao8rm-XucAmCIkRlpBz6MYKCjQgyRz3UtZCJ2DYF4lKqTjphEAgclbYZ7KiCuTn9HualwtEmVzHHFneHMKl7KnRQk-9wjgiyQ5nlsVpCCblg6JKr9of4utuPO3cBvbjhB4_ueQ40cpWVOICcOLS7_w0i3pCq1ZKDEMrYDJfz87r2sU9kw1zeFQk
index a207d9e..64850e1 100644 (file)
@@ -1,24 +1,19 @@
 SUMMARY = "Flutter Dashboard"
 DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
-
 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-dashboard"
-
-BUGTRACKER = "https://github.com/hritik-chouhan/dashboard_for_recipe/issues"
-
 SECTION = "graphics"
 
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
 
-
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-dashboard;protocol=https;branch=${AGL_BRANCH} \
-    file://dashboard_config.yaml \
-    "
+           file://dashboard.yaml \
+           file://dashboard.token \
+"
+SRCREV = "e389b9fa646f90d50e853c2dbf870cdf9f9b80b7"
 
-SRCREV = "adc3fca51b9ebfc23b503126065d97d692d0ec64"
 S = "${WORKDIR}/git"
 
-
 inherit agl-app flutter-app
 
 # flutter-app
@@ -34,9 +29,15 @@ AGL_APP_ID = "dashboard_app"
 AGL_APP_NAME = "Dashboard"
 
 do_install:append() {
-    install -d ${D}${sysconfdir}/xdg/AGL
-    install -m 0644 ${WORKDIR}/dashboard_config.yaml ${D}${sysconfdir}/xdg/AGL/
+    # VIS authorization token file for KUKSA.val should ideally not
+    # be readable by other users, but currently that's not doable
+    # until a packaging/sandboxing/MAC scheme is (re)implemented or
+    # something like OAuth is plumbed in as an alternative.
+    install -d ${D}${sysconfdir}/xdg/AGL/dashboard
+    install -m 0644 ${WORKDIR}/dashboard.yaml ${D}${sysconfdir}/xdg/AGL/
+    install -m 0644 ${WORKDIR}/dashboard.token ${D}${sysconfdir}/xdg/AGL/dashboard/
 }
 
 FILES:${PN} += "${sysconfdir}/xdg/AGL"
+RDEPENDS:${PN} += "flutter-auto"