Add navigation demo app 03/5903/8
authorTomoki Sekiyama <tomoki.sekiyama.qu@hitachi.com>
Wed, 22 Jun 2016 06:46:22 +0000 (06:46 +0000)
committerGerrit Code Review <gerrit@172.30.200.200>
Tue, 5 Jul 2016 13:39:09 +0000 (13:39 +0000)
Add the recipe for navigation demo app to recipes-demo-hmi.

Change-Id: Ia8df6a2e36d24b27e91d5239c888a05dbe990805
Signed-off-by: Tomoki Sekiyama <tomoki.sekiyama.qu@hitachi.com>
recipes-demo-hmi/Navigation/Navigation_0.0.7.bb [new file with mode: 0755]
recipes-platform/images/agl-demo-platform.bb

diff --git a/recipes-demo-hmi/Navigation/Navigation_0.0.7.bb b/recipes-demo-hmi/Navigation/Navigation_0.0.7.bb
new file mode 100755 (executable)
index 0000000..170e5cc
--- /dev/null
@@ -0,0 +1,16 @@
+LICENSE="GPLv2"
+LIC_FILES_CHKSUM="file://LICENSE;md5=3595e9c703a847d990664d2b396a9df0 \
+                  file://COPYING;md5=947b2d60ca3872e172034438e9801200"
+
+DEPENDS =        "glib-2.0 freetype sqlite3 wayland zlib expat openssl virtual/libgles2"
+RDEPENDS_${PN} = "glib-2.0 freetype sqlite3 wayland zlib expat openssl libegl libwayland-egl"
+
+SRCREV="v0.0.7"
+SRC_URI="git://github.com/gpsnavi/gpsnavi.git"
+
+# To avoid C++ library link failure
+SECURITY_CFLAGS = ""
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
index a40680d..2089e7a 100644 (file)
@@ -22,4 +22,5 @@ IMAGE_INSTALL_append = " \
     python-curses \
     dhcp-client \
     climatecontrolplugin \
+    Navigation \
     "