[homescreen] Add bitbake recipe for Home Screen app 17/6017/1
authorBocklage, Jens <Jens_Bocklage@mentor.com>
Thu, 30 Jun 2016 11:59:02 +0000 (13:59 +0200)
committerBocklage, Jens <Jens_Bocklage@mentor.com>
Thu, 30 Jun 2016 13:28:33 +0000 (15:28 +0200)
This bitbake recipe builds the Home Screen application.
In addition a sample application that shows the functionality of the status bar. The sample application SampleAppTimeDate shows the current time in the Home Screen status bar.

Signed-off-by: Bocklage, Jens <Jens_Bocklage@mentor.com>
recipes-demo-hmi/HomeScreen/HomeScreen.bb [deleted file]
recipes-demo-hmi/HomeScreen/HomeScreen_0.1.0.bb [new file with mode: 0644]

diff --git a/recipes-demo-hmi/HomeScreen/HomeScreen.bb b/recipes-demo-hmi/HomeScreen/HomeScreen.bb
deleted file mode 100644 (file)
index 681b84f..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-SUMMARY     = "${PN} for the AGL Demo Platform"
-DESCRIPTION = "${PN} app"
-HOMEPAGE    = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/${PN}"
-
-SECTION     = "apps"
-
-# To be revised once sourcecode lands
-# LICENSE     = "xyz"
-# Dummy MPL-2.0
-LICENSE     = "MPL-2.0"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
-
-
-SRC_URI     = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/${PN};protocol=http"
-SRCREV      = "AUTOINC"
-
-# custom configure and install as these are just qml files
-
-# we work in the git checkout ...
-S = "${WORKDIR}/git"
-
-do_configure() {
-    true
-}
-
-# empty folder for now
-do_install() {
-    mkdir -p ${D}/opt/AGL/${PN}/
-}
-
-FILES_${PN} = "/opt/AGL/${PN}/"
diff --git a/recipes-demo-hmi/HomeScreen/HomeScreen_0.1.0.bb b/recipes-demo-hmi/HomeScreen/HomeScreen_0.1.0.bb
new file mode 100644 (file)
index 0000000..42a61d1
--- /dev/null
@@ -0,0 +1,31 @@
+SUMMARY     = "AGL Home Screen Application"
+DESCRIPTION = "AGL Home Screen Application + Home Screen Simulator + SampleAppTimeDate"
+HOMEPAGE    = "https://wiki.automotivelinux.org/homescreen"
+LICENSE     = "Apache-2.0"
+SECTION     = "apps"
+PV          = "0.1.0+gitr${SRCPV}"
+PR          = "r1"
+S           = "${WORKDIR}/git/"
+
+inherit qmake5
+DEPENDS = "qtbase"
+
+LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+SRCREV  = "cf47f13164830e5b153db006cc55c3cf126d8d8c"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http"
+
+
+do_compile_prepend(){
+    PATH=$PATH:${STAGING_BINDIR_NATIVE}/qt5
+    export PATH
+}
+
+do_install() {
+    install -d ${D}/opt/AGL/${PN}
+    install -m 0755 ${B}/HomeScreen/HomeScreen ${D}/opt/AGL/${PN}/
+    install -m 0755 ${B}/SampleAppTimeDate/SampleAppTimeDate ${D}/opt/AGL/${PN}/
+}
+
+FILES_${PN} += "/opt/AGL/${PN}/"
+FILES_${PN}-dbg += "/opt/AGL/${PN}/.debug"
+