python3-qtpy: add recipe 43/29343/2
authorScott Murray <scott.murray@konsulko.com>
Mon, 30 Oct 2023 21:45:47 +0000 (17:45 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sat, 4 Nov 2023 14:37:10 +0000 (14:37 +0000)
Add recipe for python3-qtpy, it is needed for agl-demo-control-panel.

Bug-AGL: SPEC-4952

Change-Id: I1ce1bface3896e4760e4212593af49ff81b5165d
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29343
ci-image-build: Jenkins Job builder account
Tested-by: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Reviewed-by: Lisandro Perez Meyer <lpmeyer@ics.com>
ci-image-boot-test: Jenkins Job builder account

recipes-devtools/python/python3-qtpy_2.4.0.bb [new file with mode: 0644]

diff --git a/recipes-devtools/python/python3-qtpy_2.4.0.bb b/recipes-devtools/python/python3-qtpy_2.4.0.bb
new file mode 100644 (file)
index 0000000..8e454cb
--- /dev/null
@@ -0,0 +1,14 @@
+SUMMARY = "Abstraction layer for PyQt5/PySide2/PyQt6/PySide6"
+HOMEPAGE = "https://github.com/spyder-ide/qtpy"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b2830f54500be1314b9ec6096989f983"
+
+PYPI_PACKAGE = "QtPy"
+
+SRC_URI[sha256sum] = "db2d508167aa6106781565c8da5c6f1487debacba33519cedc35fa8997d424d4"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+    python3-pyqt5 \
+"