python3-qtpy: add recipe
[AGL/meta-agl-demo.git] / recipes-devtools / python / python3-qtpy_2.4.0.bb
1 SUMMARY = "Abstraction layer for PyQt5/PySide2/PyQt6/PySide6"
2 HOMEPAGE = "https://github.com/spyder-ide/qtpy"
3 LICENSE = "MIT"
4 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b2830f54500be1314b9ec6096989f983"
5
6 PYPI_PACKAGE = "QtPy"
7
8 SRC_URI[sha256sum] = "db2d508167aa6106781565c8da5c6f1487debacba33519cedc35fa8997d424d4"
9
10 inherit pypi setuptools3
11
12 RDEPENDS:${PN} += " \
13     python3-pyqt5 \
14 "