Add AWS SDK dependency to the cloudproxy 39/25439/2
authorAndrey Shamanin <andrei.shamanin@orioninc.com>
Thu, 15 Oct 2020 12:38:33 +0000 (15:38 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 20 Oct 2020 13:48:42 +0000 (13:48 +0000)
Bug-AGL: SPEC-3644
Signed-off-by: Andrey Shamanin <andrei.shamanin@orioninc.com>
Change-Id: I1810931aab0bc8dafc057f82517ba570a82f66fa

recipes-apis/agl-service-cloudproxy/agl-service-cloudproxy_git.bb

index 588e86f..6d40b9d 100644 (file)
@@ -11,13 +11,13 @@ SRCREV = "${AGL_APP_REVISION}"
 PV      = "1.0+git${SRCPV}"
 S       = "${WORKDIR}/git/"
 
-DEPENDS = "azure-iot-sdk-c glib-2.0"
+DEPENDS = "azure-iot-sdk-c aws-iot-device-sdk-embedded-c glib-2.0"
 
 inherit cmake aglwgt pkgconfig
 
 # Azure include files
 CXXFLAGS_prepend += "-I${STAGING_INCDIR}/azureiot"
 
-RDEPENDS_${PN} += "azure-iot-sdk-c azure-c-shared-utility"
+RDEPENDS_${PN} += "azure-iot-sdk-c azure-c-shared-utility aws-iot-device-sdk-embedded-c"
 
 BBCLASSEXTEND = "native nativesdk"