Adapt packages of agl-image-ivi-crosssdk 30/25430/1
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 14 Oct 2020 00:08:32 +0000 (02:08 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 14 Oct 2020 01:44:29 +0000 (03:44 +0200)
The agl-image-ivi-crosssdk image was missing multiple services required for CI use.

Bug-AGL: SPEC-3598
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Change-Id: Ide6a367955b9a019863d7b29e04157c94dd33f60

recipes-platform/images/agl-image-ivi-crosssdk.bb
recipes-platform/images/agl-image-ivi.bb
recipes-platform/images/agl-image-ivi.inc

index 93537fe..72bf8f7 100644 (file)
@@ -1,2 +1,9 @@
-# just for backward compatibility
-require recipes-platform/images/agl-image-minimal-crosssdk.bb
+require recipes-platform/images/agl-image-minimal-crosssdk.inc
+require agl-image-ivi.inc
+
+inherit populate_sdk
+
+# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
+# Both exec "createrepo" on the same directory, and so one of them
+# can failed (randomly).
+addtask do_populate_sdk after do_rootfs
index 1e58700..b3c72de 100644 (file)
@@ -6,8 +6,3 @@ require agl-image-ivi.inc
 
 LICENSE = "MIT"
 
-IMAGE_INSTALL_append = "\
-    packagegroup-agl-image-ivi \
-    "
-
-DISTRO_FEATURES_append = " agl-core-image-profile"
index 610d4e4..95b6ca6 100644 (file)
@@ -1,3 +1,16 @@
 require recipes-platform/images/agl-image-minimal.inc
 
+IMAGE_INSTALL_append = "\
+    packagegroup-agl-image-ivi \
+    packagegroup-agl-ivi-services \
+    agl-service-homescreen \
+    agl-service-weather \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'pipewire', '', d)} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'agl-service-mediaplayer', '', d)} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'agl-service-radio', '', d)} \
+    can-utils \
+    iproute2 \
+    "
+
 IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
+DISTRO_FEATURES_append = " agl-core-image-profile"