html5-homescreen_git: Remove autobuild script builds 37/27337/2 13.0.0 marlin/13.0.0 marlin_13.0.0
authorMarius Vlad <marius.vlad@collabora.com>
Fri, 11 Mar 2022 14:47:28 +0000 (16:47 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 29 Mar 2022 14:38:41 +0000 (14:38 +0000)
Bug-AGL: SPEC-4295

Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Change-Id: Id819f3282d4b82ec985c94484cfe24a008e22106
(cherry picked from commit d5be36be695d8ec7f8f5de01cca432621ca8e01f)

recipes-demo/html5-homescreen/html5-homescreen_git.bb

index 1d5f14a..0fdd02b 100644 (file)
@@ -17,9 +17,10 @@ SRCREV = "${AGL_APP_REVISION}"
 DEPENDS = "nodejs-native"
 
 do_compile() {
-  bldcmd=${S}/autobuild/agl/autobuild
   cd ${S}
-  $bldcmd build
+  rm -rf package node_modules package-lock.json
+  npm install
+  npm run build
 }
 
 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
@@ -38,4 +39,4 @@ FILES_${PN} = " \
 "
 
 RCONFLICTS_${PN} = "homescreen"
-RDEPENDS_${PN} = "applaunchd html5-background"
\ No newline at end of file
+RDEPENDS_${PN} = "applaunchd html5-background"