html5-homescreen_git: Remove autobuild script builds
[AGL/meta-agl-demo.git] / recipes-demo / html5-homescreen / html5-homescreen_git.bb
1 SUMMARY     = "AGL HTML5 Homescreen"
2 HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-homescreen/"
3 SECTION     = "apps"
4 LICENSE     = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7 PV      = "1.0+git${SRCPV}"
8 S       = "${WORKDIR}/git"
9 B       = "${WORKDIR}/build"
10
11 SRC_URI = " \
12   git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=${AGL_BRANCH} \
13   file://homescreen.service \
14 "
15 SRCREV = "${AGL_APP_REVISION}"
16
17 DEPENDS = "nodejs-native"
18
19 do_compile() {
20   cd ${S}
21   rm -rf package node_modules package-lock.json
22   npm install
23   npm run build
24 }
25
26 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
27
28 do_install() {
29   install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
30   cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
31   install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
32   install -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
33   ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
34 }
35
36 FILES_${PN} = " \
37   ${WAM_APPLICATIONS_DIR}/${PN} \
38   ${systemd_user_unitdir} \
39 "
40
41 RCONFLICTS_${PN} = "homescreen"
42 RDEPENDS_${PN} = "applaunchd html5-background"