Fix crosssdk image creation 09/8409/1
authorRonan Le Martret <ronan.lemartret@iot.bzh>
Tue, 31 Jan 2017 15:07:59 +0000 (16:07 +0100)
committerRonan Le Martret <ronan.lemartret@iot.bzh>
Tue, 31 Jan 2017 15:07:59 +0000 (16:07 +0100)
 * Task do_populate_sdk and do_rootfs can't be exec simultaneously.
 * Both exec "createrepo" on the same directory, and so one of them
 * can failed (randomly).

Change-Id: I72d2b5dce49bfdab41e9882c5c67b8541327551e
Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
recipes-platform/images/agl-demo-platform-crosssdk.bb

index e6225be..9765015 100644 (file)
@@ -10,3 +10,8 @@ IMAGE_FEATURES_append = "dev-pkgs"
 IMAGE_INSTALL_append = "kernel-dev"
 
 inherit populate_sdk populate_sdk_qt5
+
+# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
+# Both exec "createrepo" on the same directory, and so one of them
+# can failed (randomly).
+addtask do_populate_sdk after do_rootfs