meta-agl-demo: recipes-kernel: update MOST driver recipes 49/8349/4
authorChristian Gromm <christian.gromm@microchip.com>
Tue, 24 Jan 2017 12:48:26 +0000 (13:48 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 27 Jan 2017 01:03:46 +0000 (01:03 +0000)
This patch updates the recipes used to build the MOST driver.
Since the driver source directory holds version 1.4.0-stable
as of commit f19c18408b515c5e33f96893cbe213d9ab30b904 it also
adds backport patches for the MOST sound and networking driver
needed to build for porter.

v2 (jsmoeller): combine with c8359

Change-Id: Ie56cadf9ef6224afb585fe950a0c3b0aff53b572
Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
12 files changed:
recipes-kernel/aim-cdev/aim-cdev.bb
recipes-kernel/aim-network/aim-network.bb
recipes-kernel/aim-network/files/0001-aim-network-backport-patch-for-3.10.31-ltsi.patch [new file with mode: 0644]
recipes-kernel/aim-sound/aim-sound.bb
recipes-kernel/aim-sound/files/0001-aim-sound-3.10.31-ltsi-backport.patch [new file with mode: 0644]
recipes-kernel/aim-v4l2/aim-v4l2.bb
recipes-kernel/hdm-dim2/hdm-dim2.bb
recipes-kernel/hdm-i2c/hdm-i2c.bb
recipes-kernel/hdm-usb/hdm-usb.bb
recipes-kernel/mocca-usb/mocca-usb.bb
recipes-kernel/mostcore/mostcore.bb
recipes-platform/images/agl-demo-platform.bb

index 66a294b..09c24ce 100644 (file)
@@ -1,8 +1,6 @@
-DESCRIPTION = "Example of how to build an external Linux kernel module"
+DESCRIPTION = "Build character device driver for MOST"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
-#                 "  
 
 inherit module
 
@@ -11,8 +9,7 @@ PV = "0.1"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
 
 S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
-#SRCREV = "${AUTOREV}"
+SRCREV = "${AUTOREV}"
 
 # The inherit of module.bbclass will automatically name module packages with
 # "kernel-module-" prefix as required by the oe-core build environment.
@@ -24,6 +21,3 @@ do_install_append () {
         echo "aim_cdev" > ${D}${sysconfdir}/modules-load.d/aim_cdev.conf
     fi
 }
-
-# These sources are currently for the porter kernel only
-COMPATIBLE_MACHINE = "porter"
index ce504ea..b731f93 100644 (file)
@@ -1,18 +1,16 @@
-DESCRIPTION = "Example of how to build an external Linux kernel module"
+DESCRIPTION = "Build networking driver for MOST"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
-#                 "  
 
 inherit module
 
 PV = "0.1"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
+SRC_URI_append_porter = " file://0001-aim-network-backport-patch-for-3.10.31-ltsi.patch"
 
 S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
-#SRCREV = "${AUTOREV}"
+SRCREV = "${AUTOREV}"
 
 # The inherit of module.bbclass will automatically name module packages with
 # "kernel-module-" prefix as required by the oe-core build environment.
@@ -24,6 +22,3 @@ do_install_append () {
         echo "aim_network" > ${D}${sysconfdir}/modules-load.d/aim_network.conf
     fi
 }
-
-# These sources are currently for the porter kernel only
-COMPATIBLE_MACHINE = "porter"
diff --git a/recipes-kernel/aim-network/files/0001-aim-network-backport-patch-for-3.10.31-ltsi.patch b/recipes-kernel/aim-network/files/0001-aim-network-backport-patch-for-3.10.31-ltsi.patch
new file mode 100644 (file)
index 0000000..41728c2
--- /dev/null
@@ -0,0 +1,45 @@
+From 4c49b7ad9e3c1e64e4e6042e6fee357b5d9b3df2 Mon Sep 17 00:00:00 2001
+From: Christian Gromm <christian.gromm@microchip.com>
+Date: Mon, 23 Jan 2017 14:57:55 +0100
+Subject: [PATCH] aim-network: create backport patch for 3.10.31-ltsi
+
+Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
+---
+ aim-network/networking.c | 7 +++----
+ 1 file changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/networking.c b/aim-network/networking.c
+index ce1764c..e04b523 100644
+--- a/networking.c
++++ b/networking.c
+@@ -362,8 +362,7 @@ static int aim_probe_channel(struct most_interface *iface, int channel_idx,
+       if (nd->tx.linked || nd->rx.linked) {
+               struct net_device *dev =
+-                      alloc_netdev(0, "meth%d", NET_NAME_UNKNOWN,
+-                                   most_nd_setup);
++                      alloc_netdev(0, "meth%d", most_nd_setup);
+               if (!dev) {
+                       pr_err("no memory for net_device\n");
+@@ -483,7 +482,7 @@ static int aim_rx_data(struct mbo *mbo)
+       if (nd->is_mamac) {
+               /* dest */
+-              ether_addr_copy(skb_put(skb, ETH_ALEN), dev->dev_addr);
++              memcpy(skb_put(skb, ETH_ALEN), dev->dev_addr, ETH_ALEN);
+               /* src */
+               memcpy(skb_put(skb, 4), &zero, 4);
+@@ -577,7 +576,7 @@ void most_deliver_netinfo(struct most_interface *iface,
+               if (!is_valid_ether_addr(dev->dev_addr)) {
+                       netdev_info(dev, "set mac %02x-%02x-%02x-%02x-%02x-%02x\n",
+                                   m[0], m[1], m[2], m[3], m[4], m[5]);
+-                      ether_addr_copy(dev->dev_addr, m);
++                      memcpy(dev->dev_addr, m, ETH_ALEN);
+                       complete(&nd->mac_compl);
+               } else if (!ether_addr_equal(dev->dev_addr, m)) {
+                       netdev_warn(dev, "reject mac %02x-%02x-%02x-%02x-%02x-%02x\n",
+-- 
+2.11.0
+
index 3740d25..ae8d7d8 100644 (file)
@@ -1,18 +1,16 @@
-DESCRIPTION = "Example of how to build an external Linux kernel module"
+DESCRIPTION = "Build ALSA driver for MOST"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
-#                 "  
 
 inherit module
 
 PV = "0.1"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
+SRC_URI_append_porter = " file://0001-aim-sound-3.10.31-ltsi-backport.patch"
 
 S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
-#SRCREV = "${AUTOREV}"
+SRCREV = "${AUTOREV}"
 
 # The inherit of module.bbclass will automatically name module packages with
 # "kernel-module-" prefix as required by the oe-core build environment.
@@ -24,6 +22,3 @@ do_install_append () {
         echo "aim_sound" > ${D}${sysconfdir}/modules-load.d/aim_sound.conf
     fi
 }
-
-# These sources are currently for the porter kernel only
-COMPATIBLE_MACHINE = "porter"
diff --git a/recipes-kernel/aim-sound/files/0001-aim-sound-3.10.31-ltsi-backport.patch b/recipes-kernel/aim-sound/files/0001-aim-sound-3.10.31-ltsi-backport.patch
new file mode 100644 (file)
index 0000000..b999b0d
--- /dev/null
@@ -0,0 +1,29 @@
+From 686130266ff7968edc863d398fba82bd0f78bf29 Mon Sep 17 00:00:00 2001
+From: Christian Gromm <christian.gromm@microchip.com>
+Date: Wed, 28 Sep 2016 13:43:36 +0200
+Subject: [PATCH 1/4] backport module
+
+This patch replaces function snd_card_new() with snd_card_create() to match
+AGL/Renesas kernel API.
+
+Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
+---
+ aim-sound/sound.c |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/sound.c b/aim-sound/sound.c
+index 3dc625c..af0af2d 100644
+--- a/sound.c
++++ b/sound.c
+@@ -595,7 +595,7 @@ static int audio_probe_channel(struct most_interface *iface, int channel_id,
+               return ret;
+       }
+-      ret = snd_card_new(NULL, -1, card_name, THIS_MODULE,
++      ret = snd_card_create(-1, card_name, THIS_MODULE,
+                          sizeof(*channel), &card);
+       if (ret < 0)
+               return ret;
+-- 
+1.7.9.5
+
index c326103..41dbf6d 100644 (file)
@@ -1,8 +1,6 @@
-DESCRIPTION = "Example of how to build an external Linux kernel module"
+DESCRIPTION = "Build V4L2 driver for MOST"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
-#                 "  
 
 inherit module
 
@@ -11,8 +9,7 @@ PV = "0.1"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
 
 S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
-#SRCREV = "${AUTOREV}"
+SRCREV = "${AUTOREV}"
 
 # The inherit of module.bbclass will automatically name module packages with
 # "kernel-module-" prefix as required by the oe-core build environment.
@@ -24,6 +21,3 @@ do_install_append () {
         echo "aim_v4l2" > ${D}${sysconfdir}/modules-load.d/aim_v4l2.conf
     fi
 }
-
-# These sources are currently for the porter kernel only
-COMPATIBLE_MACHINE = "porter"
index 3a73e5e..6e156f1 100644 (file)
@@ -1,8 +1,6 @@
-DESCRIPTION = "Example of how to build an external Linux kernel module"
+DESCRIPTION = "Build DIM2 adapter driver for MOST"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
-#                 "  
 
 inherit module
 
@@ -11,8 +9,7 @@ PV = "0.1"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
 
 S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
-#SRCREV = "${AUTOREV}"
+SRCREV = "${AUTOREV}"
 
 # The inherit of module.bbclass will automatically name module packages with
 # "kernel-module-" prefix as required by the oe-core build environment.
@@ -24,6 +21,3 @@ do_install_append () {
         echo "hdm_dim2" > ${D}${sysconfdir}/modules-load.d/hdm_dim2.conf
     fi
 }
-
-# These sources are currently for the porter kernel only
-COMPATIBLE_MACHINE = "porter"
index 92184af..e1e93ee 100644 (file)
@@ -1,8 +1,6 @@
-DESCRIPTION = "Example of how to build an external Linux kernel module"
+DESCRIPTION = "Build I2C adapter driver for MOST"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
-#                 "  
 
 inherit module
 
@@ -11,8 +9,7 @@ PV = "0.1"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
 
 S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
-#SRCREV = "${AUTOREV}"
+SRCREV = "${AUTOREV}"
 
 # The inherit of module.bbclass will automatically name module packages with
 # "kernel-module-" prefix as required by the oe-core build environment.
@@ -24,6 +21,3 @@ do_install_append () {
         echo "hdm_i2c" > ${D}${sysconfdir}/modules-load.d/hdm_i2c.conf
     fi
 }
-
-# These sources are currently for the porter kernel only
-COMPATIBLE_MACHINE = "porter"
index 4174127..4c1ef8a 100644 (file)
@@ -1,8 +1,6 @@
-DESCRIPTION = "Example of how to build an external Linux kernel module"
+DESCRIPTION = "Build USB adapter driver for MOST"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
-#                 "  
 
 inherit module
 
@@ -11,8 +9,7 @@ PV = "0.1"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
 
 S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
-#SRCREV = "${AUTOREV}"
+SRCREV = "${AUTOREV}"
 
 # The inherit of module.bbclass will automatically name module packages with
 # "kernel-module-" prefix as required by the oe-core build environment.
@@ -24,6 +21,3 @@ do_install_append () {
         echo "hdm_usb" > ${D}${sysconfdir}/modules-load.d/hdm_usb.conf
     fi
 }
-
-# These sources are currently for the porter kernel only
-COMPATIBLE_MACHINE = "porter"
index 59bcf7a..246f25b 100644 (file)
@@ -1,4 +1,4 @@
-DESCRIPTION = "Example of how to build an external Linux kernel module"
+DESCRIPTION = "Build USB driver for MOCCA box"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
@@ -20,6 +20,3 @@ do_install_append () {
         echo "mocca_usb" > ${D}${sysconfdir}/modules-load.d/mocca_usb.conf
     fi
 }
-
-# These sources are currently for the porter kernel only
-COMPATIBLE_MACHINE = "porter"
index 368b85a..35865ce 100644 (file)
@@ -1,8 +1,6 @@
-DESCRIPTION = "Example of how to build an external Linux kernel module"
+DESCRIPTION = "Build MOST core driver"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
-#                 "  
 
 inherit module
 
@@ -11,8 +9,7 @@ PV = "0.1"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
 
 S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "7850efa9077fa84536e0442c65d39a36e25e39d1"
-#SRCREV = "${AUTOREV}"
+SRCREV = "${AUTOREV}"
 
 # The inherit of module.bbclass will automatically name module packages with
 # "kernel-module-" prefix as required by the oe-core build environment.
@@ -24,6 +21,3 @@ do_install_append () {
         echo "mostcore" > ${D}${sysconfdir}/modules-load.d/mostcore.conf
     fi
 }
-
-# These sources are currently for the porter kernel only
-COMPATIBLE_MACHINE = "porter"
index 2c9047e..ff64f13 100644 (file)
@@ -27,7 +27,7 @@ IMAGE_TTF_FONTS = " \
 # Only for porter as these kernel module sources
 # are for the 3.10.x kernel only
 MOST_DRIVERS = " "
-MOST_DRIVERS_append_porter = " \
+MOST_DRIVERS_append = " \
     aim-cdev \
     aim-network \
     aim-sound \
@@ -41,7 +41,7 @@ MOST_DRIVERS_append_porter = " \
 
 # HVAC dependencies depend on drivers above
 IMAGE_MOST_HVAC = " "
-IMAGE_MOST_HVAC_append_porter = " \
+IMAGE_MOST_HVAC_append = " \
     ${MOST_DRIVERS} \
     unicens \
     vod-server \