Change libhomescreen-2017 to libhomescreen 87/16487/1 5.99.6 flounder/5.99.6 flounder_5.99.6
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>
Fri, 7 Sep 2018 07:47:34 +0000 (16:47 +0900)
committerzheng_wenlong <wenlong_zheng@nexty-ele.com>
Fri, 7 Sep 2018 07:48:43 +0000 (16:48 +0900)
    Change libhomescreen-2017 to libhomescreen recipes,
    Detele libhomescreen-2017 recipes.

Change-Id: Ib87676fb34a593fedb72ca635a49742578c40efc
Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
16 files changed:
recipes-demo-hmi/als-meter-demo/als-meter-demo_git.bb
recipes-demo-hmi/homescreen/homescreen_git.bb
recipes-demo-hmi/hvac/hvac_git.bb
recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb [deleted file]
recipes-demo-hmi/libhomescreen/libhomescreen/homescreen.pc.in [deleted file]
recipes-demo-hmi/libhomescreen/libhomescreen/org.agl.statusbar.conf [moved from recipes-demo-hmi/libhomescreen/libhomescreen-2017/org.agl.statusbar.conf with 100% similarity]
recipes-demo-hmi/libhomescreen/libhomescreen_git.bb
recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
recipes-demo-hmi/mixer/mixer_git.bb
recipes-demo-hmi/navigation/navigation-demo_git.bb
recipes-demo-hmi/navigation/navigation_git.bb
recipes-demo-hmi/navigation/poiapp_git.bb
recipes-demo-hmi/phone/phone_git.bb
recipes-demo-hmi/qtaglextras/qtaglextras_git.bb
recipes-demo-hmi/radio/radio_git.bb
recipes-demo-hmi/settings/settings_git.bb

index 866bcce..6b0e054 100644 (file)
@@ -13,7 +13,7 @@ PV = "0.1+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS += "qtquickcontrols2 opencv virtual/libhomescreen qlibwindowmanager"
+DEPENDS += "qtquickcontrols2 opencv libhomescreen qlibwindowmanager"
 
 # runtime dependencies
 RDEPENDS_${PN} += "agl-service-steering-wheel"
index 014c1ae..74e3383 100644 (file)
@@ -15,7 +15,7 @@ DEPENDS = "\
         agl-service-weather \
         libqtappfw \
         qlibwindowmanager \
-        virtual/libhomescreen \
+        libhomescreen \
 "
 
 inherit qmake5 systemd pkgconfig aglwgt
index 3290ca9..d0ed42c 100644 (file)
@@ -13,6 +13,6 @@ PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS += "qtquickcontrols2 virtual/libhomescreen qlibwindowmanager qttools-native"
+DEPENDS += "qtquickcontrols2 libhomescreen qlibwindowmanager qttools-native"
 
 inherit qmake5 aglwgt
diff --git a/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb b/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
deleted file mode 100644 (file)
index 5c84ebe..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-SUMMARY     = "AGL Home Screen Library"
-DESCRIPTION = "libhomescreen"
-HOMEPAGE    = "http://docs.automotivelinux.org"
-LICENSE     = "Apache-2.0"
-SECTION     = "libs"
-
-BBCLASSEXTEND = " nativesdk"
-
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-
-DEPENDS = "af-binder json-c"
-
-inherit cmake
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
-          file://org.agl.statusbar.conf \
-         "
-SRCREV = "d22ffadbe9fcb13144264e71da300bdf56724906"
-S = "${WORKDIR}/git"
-
-do_install_append() {
-       mkdir -p ${D}${sysconfdir}/dbus-1/session.d
-       install -m 0644 ${WORKDIR}/org.agl.statusbar.conf  ${D}${sysconfdir}/dbus-1/session.d
-}
-
-RDEPENDS_${PN} = "agl-service-homescreen"
-PROVIDES += "virtual/libhomescreen"
diff --git a/recipes-demo-hmi/libhomescreen/libhomescreen/homescreen.pc.in b/recipes-demo-hmi/libhomescreen/libhomescreen/homescreen.pc.in
deleted file mode 100644 (file)
index 7d9ee1e..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-prefix=OEPREFIX
-exec_prefix=OEPREFIX
-libdir=OELIBDIR
-includedir=OEINCDIR
-
-Name: libhomescreen
-Description: A generic interface for the HomeScreen app
-Version: 1.0.0
-Libs: -L${libdir} -lhomescreen
-Libs.private: -lgio-2.0 -lgobject-2.0 -lglib-2.0
-Cflags:
-Requires: glib-2.0 gio-unix-2.0
index b71b5b4..bc9aa6e 100644 (file)
@@ -6,61 +6,21 @@ SECTION     = "libs"
 
 BBCLASSEXTEND = " nativesdk"
 
-LIC_FILES_CHKSUM = "file://libhomescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-DEPENDS += " glib-2.0 "
+DEPENDS = "af-binder json-c"
 
-inherit qmake5 pkgconfig
+inherit cmake
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
-           file://homescreen.pc.in"
-SRCREV  = "f5c14333d2170ae9babed53ea530828569a830ff"
-S       = "${WORKDIR}/git/"
-
-# PV needs to be modified with SRCPV to work AUTOREV correctly
-PV = "0.0+git${SRCPV}"
-
-do_install() {
-    install -d ${D}/usr/AGL/${PN}
-    install -m 0755 ${B}/samplehomescreeninterfaceapp/SampleHomeScreenInterfaceApp ${D}/usr/AGL/${PN}/
-
-    install -d ${D}${libdir}
-    install -m 0644 ${B}/libhomescreen/libhomescreen.so.1.0.0 ${D}${libdir}/
-    ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so
-    ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1
-    ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
-
-# kooltux: still some problem with paths inside .pc file
-# error at build time:
-# ERROR: homescreen-git-r0 do_populate_sysroot: QA Issue: homescreen.pc failed sanity test (tmpdir) in path /xdt/build/tmp/work/cortexa15hf-neon-agl-linux-gnueabi/libhomescreen/git-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig]
-#
-    install -d ${D}${libdir}/pkgconfig
-    install -m 0644 ${WORKDIR}/homescreen.pc.in ${D}${libdir}/pkgconfig/homescreen.pc
-    sed -i s:OEPREFIX:${prefix}:g ${D}${libdir}/pkgconfig/homescreen.pc
-    sed -i s:OELIBDIR:${libdir}:g ${D}${libdir}/pkgconfig/homescreen.pc
-    sed -i s:OEINCDIR:${includedir}:g ${D}${libdir}/pkgconfig/homescreen.pc
-
-    install -d ${D}${includedir}
-    install -m 0644 ${S}/libhomescreen/include/libhomescreen.hpp ${D}${includedir}/
+          file://org.agl.statusbar.conf \
+         "
+SRCREV = "d22ffadbe9fcb13144264e71da300bdf56724906"
+S = "${WORKDIR}/git"
+
+do_install_append() {
+       mkdir -p ${D}${sysconfdir}/dbus-1/session.d
+       install -m 0644 ${WORKDIR}/org.agl.statusbar.conf  ${D}${sysconfdir}/dbus-1/session.d
 }
 
-PACKAGES =+ "libhomescreensampleapp libhomescreensampleapp-dbg"
-
-FILES_${PN} = "\
-       ${libdir}/libhomescreen.so.* \
-"
-FILES_${PN}-dev = "\
-       ${includedir}/libhomescreen.hpp \
-       ${libdir}/libhomescreen.so \
-       ${libdir}/pkgconfig/homescreen.pc \
-"
-FILES_${PN}-dbg += "\
-       ${libdir}/.debug/libhomescreen.so.* \
-"
-
-FILES_libhomescreensampleapp += "/usr/AGL/${PN}/SampleHomeScreenInterfaceApp"
-FILES_libhomescreensampleapp-dbg += "/usr/AGL/${PN}/.debug"
-
-
-RDEPENDS_libhomescreensampleapp-dbg += "${PN}-dbg ${PN}-dev"
-PROVIDES += "virtual/libhomescreen"
+RDEPENDS_${PN} = "agl-service-homescreen"
index c6ac66e..ef39fdf 100644 (file)
@@ -16,7 +16,7 @@ S  = "${WORKDIR}/git"
 DEPENDS += "qtquickcontrols2 \
             qtwebsockets \
             libqtappfw \
-            virtual/libhomescreen \
+            libhomescreen \
             qlibwindowmanager \
 "
 
index 130ee1d..b721970 100644 (file)
@@ -17,7 +17,7 @@ S  = "${WORKDIR}/git"
 # build-time dependencies
 DEPENDS += "qtquickcontrols2 \
             pulseaudio \
-            virtual/libhomescreen \
+            libhomescreen \
             qlibwindowmanager \
 "
 
index 71195b3..b1d0407 100644 (file)
@@ -16,7 +16,7 @@ S  = "${WORKDIR}/git"
 RPROVIDES_${PN} = "virtual/navigation"
 
 DEPENDS  += "qtquickcontrols2 \
-             virtual/libhomescreen \
+             libhomescreen \
              qlibwindowmanager \
              qtvirtualkeyboard \
              qtlocation \
index 1e6ffb9..f35a275 100755 (executable)
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM="file://LICENSE;md5=3595e9c703a847d990664d2b396a9df0 \
 
 DEPENDS = " \
           glib-2.0 freetype sqlite3 wayland zlib expat openssl virtual/libgles2 virtual/libgl virtual/egl \
-          wayland libdbus-c++ af-main af-binder libwindowmanager virtual/libhomescreen \
+          wayland libdbus-c++ af-main af-binder libwindowmanager libhomescreen \
           "
 
 RDEPENDS_${PN} = " flite openjtalk glib-2.0 freetype sqlite3 wayland zlib expat openssl \
index 94753fe..d29c860 100755 (executable)
@@ -10,7 +10,7 @@ inherit cmake_qt5 pkgconfig
 inherit aglwgt
 
 DEPENDS += " qtbase json-c libnaviapi-agl \
-             af-binder qlibwindowmanager virtual/libhomescreen \
+             af-binder qlibwindowmanager libhomescreen \
            "
 
 RDEPENDS_${PN} =  " qtbase \
index 7a9f628..011789a 100644 (file)
@@ -16,7 +16,7 @@ S  = "${WORKDIR}/git"
 DEPENDS += "qtquickcontrols2 \
             qtmultimedia \
             libqtappfw \
-            virtual/libhomescreen \
+            libhomescreen \
             qlibwindowmanager \
 "
 
index 1901e7a..765dc14 100644 (file)
@@ -1,7 +1,7 @@
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
-DEPENDS += "qtbase qtdeclarative qtquickcontrols2 qlibwindowmanager virtual/libhomescreen"
+DEPENDS += "qtbase qtdeclarative qtquickcontrols2 qlibwindowmanager libhomescreen"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qtaglextras;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_DEFAULT_REVISION}"
index dedfd1f..915ece9 100644 (file)
@@ -19,7 +19,7 @@ S  = "${WORKDIR}/git"
 
 # build-time dependencies
 DEPENDS = "qtquickcontrols2 rtl-sdr"
-DEPENDS += "virtual/libhomescreen qlibwindowmanager"
+DEPENDS += "libhomescreen qlibwindowmanager"
 
 inherit qmake5 aglwgt
 
index d6b2b1e..3604082 100644 (file)
@@ -14,7 +14,7 @@ S  = "${WORKDIR}/git"
 
 # build-time dependencies
 DEPENDS += "libqtappfw qtquickcontrols2 qtwebsockets"
-DEPENDS += "virtual/libhomescreen qlibwindowmanager qtvirtualkeyboard"
+DEPENDS += "libhomescreen qlibwindowmanager qtvirtualkeyboard"
 
 # runtime dependencies
 RDEPENDS_${PN} += " \