Add agl-service-homescreen recipes without -2017 59/16459/3
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>
Mon, 3 Sep 2018 02:25:13 +0000 (11:25 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 6 Sep 2018 16:58:16 +0000 (16:58 +0000)
    Add a new recipes named agl-service-homescreen without -2017.

Change-Id: Icdba5fa25838ab63506850b1a6641b1dfb269700
BUG-AGL: SPEC-1550
Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
recipes-demo-hmi/agl-service-homescreen/agl-service-homescreen_git.bb [new file with mode: 0644]
recipes-demo-hmi/homescreen/homescreen_git.bb
recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb

diff --git a/recipes-demo-hmi/agl-service-homescreen/agl-service-homescreen_git.bb b/recipes-demo-hmi/agl-service-homescreen/agl-service-homescreen_git.bb
new file mode 100644 (file)
index 0000000..d2481fe
--- /dev/null
@@ -0,0 +1,14 @@
+SUMMARY     = "Homescreen binding and client library for application"
+DESCRIPTION = "agl-service-homescreen is the binding library"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-homescreen"
+SECTION     = "HMI"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "dbus glib-2.0 af-binder json-c"
+
+inherit cmake aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-homescreen;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "67962d9837ea37b10c2cf906cbde575cce18ab4b"
+S = "${WORKDIR}/git"
index f9b02e9..014c1ae 100644 (file)
@@ -10,7 +10,7 @@ DEPENDS = "\
         qtdeclarative \
         qtquickcontrols2 \
         pulseaudio \
-        agl-service-homescreen-2017 \
+        agl-service-homescreen \
         agl-service-windowmanager-2017 \
         agl-service-weather \
         libqtappfw \
index 1bb4e2b..5c84ebe 100644 (file)
@@ -23,5 +23,5 @@ do_install_append() {
        install -m 0644 ${WORKDIR}/org.agl.statusbar.conf  ${D}${sysconfdir}/dbus-1/session.d
 }
 
-RDEPENDS_${PN} = "agl-service-homescreen-2017"
+RDEPENDS_${PN} = "agl-service-homescreen"
 PROVIDES += "virtual/libhomescreen"