mixer: update to build the pipewire mixer from master 73/21573/4
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.com>
Mon, 10 Jun 2019 11:51:35 +0000 (14:51 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 11 Jun 2019 13:53:50 +0000 (13:53 +0000)
Most changes are based on the 4a-mixer recipe

Bug-AGL: SPEC-2473

Change-Id: I290c97836830b1b83d9564dda2c77b526f474f18
Signed-off-by: George Kiagiadakis <george.kiagiadakis@collabora.com>
recipes-demo-hmi/mixer/mixer_git.bb

index b721970..9524bed 100644 (file)
@@ -1,5 +1,5 @@
 SUMMARY     = "Mixer for CES2017 AGL Demonstration"
-DESCRIPTION = "AGL HMI application for control of PulseAudio mixer elements"
+DESCRIPTION = "AGL HMI application for control of PipeWire mixer elements"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mixer"
 SECTION     = "apps"
 
@@ -7,21 +7,23 @@ LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
-
-# 'legacy' version (eel_5.0.3 == master for CES'18) when 4A is not enabled
-SRCREV  = "d9bb450ee8898cb810027897a32afd3adcb05d9f"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
 DEPENDS += "qtquickcontrols2 \
-            pulseaudio \
-            libhomescreen \
-            qlibwindowmanager \
+            qtwebsockets \
+            qtaglextras \
+            libafb-helpers-qt \
 "
 
+RDEPENDS_${PN} += "agl-service-audiomixer"
+
 PROVIDES += "virtual/mixer"
 RPROVIDES_${PN} += "virtual/mixer"
 
-inherit qmake5 aglwgt
+inherit cmake_qt5 aglwgt
+
+OECMAKE_CXX_FLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"