b721970f15cedc5b3d60b2bc9e437890ddf36219
[AGL/meta-agl-demo.git] / recipes-demo-hmi / mixer / mixer_git.bb
1 SUMMARY     = "Mixer for CES2017 AGL Demonstration"
2 DESCRIPTION = "AGL HMI application for control of PulseAudio mixer elements"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mixer"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
10
11 # 'legacy' version (eel_5.0.3 == master for CES'18) when 4A is not enabled
12 SRCREV  = "d9bb450ee8898cb810027897a32afd3adcb05d9f"
13
14 PV = "1.0+git${SRCPV}"
15 S  = "${WORKDIR}/git"
16
17 # build-time dependencies
18 DEPENDS += "qtquickcontrols2 \
19             pulseaudio \
20             libhomescreen \
21             qlibwindowmanager \
22 "
23
24 PROVIDES += "virtual/mixer"
25 RPROVIDES_${PN} += "virtual/mixer"
26
27 inherit qmake5 aglwgt