mapviewer: Upgrade to thud 69/21569/2
authorHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
Mon, 10 Jun 2019 09:57:42 +0000 (18:57 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 10 Jun 2019 19:34:36 +0000 (19:34 +0000)
mapviewer has link error.
This error is same as navigation app at
5f5a1fb6ea4fd884040ef3175f478321651afeab in meta-agl-demo
Then we apply the same patch file to mapviewer.

Bug-AGL : SPEC-2420

Change-Id: Ibaad718ccd3995860294e2648e884af8ba3c01df
Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
recipes-demo-hmi/navigation/mapviewer/0002-openssl-1.1-fixes.patch [new file with mode: 0644]
recipes-demo-hmi/navigation/mapviewer_git.bb

diff --git a/recipes-demo-hmi/navigation/mapviewer/0002-openssl-1.1-fixes.patch b/recipes-demo-hmi/navigation/mapviewer/0002-openssl-1.1-fixes.patch
new file mode 100644 (file)
index 0000000..9506ce1
--- /dev/null
@@ -0,0 +1,31 @@
+gpsnavi: Fix compilation with OpenSSL 1.1
+
+Handle the ERR_load_crypto_strings and ERR_free_strings functions no
+longer being present in OpenSSL 1.1.
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+diff --git a/src/sms/sms-core/SMCAL/SMCAL.c b/src/sms/sms-core/SMCAL/SMCAL.c
+index eadab8f..2dfe1f3 100755
+--- a/src/sms/sms-core/SMCAL/SMCAL.c
++++ b/src/sms/sms-core/SMCAL/SMCAL.c
+@@ -158,7 +158,9 @@ void SC_CAL_Initialize_OpenSSL() {
+       // 初期化\r
+       ERR_load_BIO_strings();\r
+       SSL_load_error_strings();\r
++#if OPENSSL_VERSION_NUMBER < 0x10100000L\r
+       ERR_load_crypto_strings();\r
++#endif\r
+       OpenSSL_add_all_algorithms();\r
\r
+       // SSLの初期化(戻り値は常に1)\r
+@@ -542,7 +544,9 @@ E_SC_CAL_RESULT SC_CAL_DisConnect(SMCAL *cal)
+                       if (NULL != cal->ssl.ctx) {\r
+                               SSL_CTX_free((SSL_CTX*)cal->ssl.ctx);\r
+                       }\r
++#if OPENSSL_VERSION_NUMBER < 0x10100000L\r
+                       ERR_free_strings();\r
++#endif\r
\r
+                       cal->ssl.ssl = NULL;\r
+                       cal->ssl.ctx = NULL;\r
index 06fea24..1922e7f 100755 (executable)
@@ -15,7 +15,9 @@ DEPENDS = " \
 RDEPENDS_${PN} = " navigation "
 
 SRCREV="2dfef5e9141ccb11f83d141c6a7dcbe0ecd49e84"
-SRC_URI="git://github.com/AGLExport/mapviwer.git"
+SRC_URI="git://github.com/AGLExport/mapviwer.git \
+         file://0002-openssl-1.1-fixes.patch \
+"
 
 # To avoid C++ library link failure
 SECURITY_CFLAGS = ""