mapviewer: Upgrade to thud
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / mapviewer_git.bb
1 SUMMARY     = "AGL meter demo application."
2 DESCRIPTION = "This application provides the function of Meter cluster to AGL. "
3 HOMEPAGE    = "https://github.com/AGLExport/mapviwer"
4 SECTION     = "apps"
5
6 LICENSE="GPLv2"
7 LIC_FILES_CHKSUM="file://LICENSE;md5=3595e9c703a847d990664d2b396a9df0 \
8                   file://COPYING;md5=947b2d60ca3872e172034438e9801200"
9
10 DEPENDS = " \
11           glib-2.0 freetype sqlite3 wayland zlib expat openssl virtual/libgles2 virtual/libgl virtual/egl \
12           wayland \
13           "
14
15 RDEPENDS_${PN} = " navigation "
16
17 SRCREV="2dfef5e9141ccb11f83d141c6a7dcbe0ecd49e84"
18 SRC_URI="git://github.com/AGLExport/mapviwer.git \
19          file://0002-openssl-1.1-fixes.patch \
20 "
21
22 # To avoid C++ library link failure
23 SECURITY_CFLAGS = ""
24
25 inherit autotools pkgconfig
26
27 S = "${WORKDIR}/git"
28