Provisional fix of libhomescreen's pkgconfig 71/7571/2
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Tue, 13 Dec 2016 12:24:19 +0000 (21:24 +0900)
committerNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Tue, 13 Dec 2016 13:54:49 +0000 (22:54 +0900)
Since pkgconfig has been disabled, it is not possible to get the configuration of libhomescreen.
This patch will make provisional fixes for off-tree build.

Change-Id: Ifd8e5818602ab1c4bca4440e1f20b3de46ab5157
Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
recipes-demo-hmi/homescreen/homescreen/homescreen.pc.in [new file with mode: 0644]
recipes-demo-hmi/homescreen/homescreen_git.bb

diff --git a/recipes-demo-hmi/homescreen/homescreen/homescreen.pc.in b/recipes-demo-hmi/homescreen/homescreen/homescreen.pc.in
new file mode 100644 (file)
index 0000000..1a70c9a
--- /dev/null
@@ -0,0 +1,14 @@
+prefix=OEPREFIX
+exec_prefix=OEPREFIX
+libdir=OELIBDIR
+includedir=OEINCDIR
+
+
+Name: libhomescreen
+Description: A generic interface for the HomeScreen app
+Version: 1.0.0
+Libs: -L${libdir} -lhomescreen 
+Libs.private: -lgio-2.0 -lgobject-2.0 -lglib-2.0   
+Cflags: 
+Requires: glib-2.0 gio-unix-2.0
+
index 7bef3a2..e03b14d 100644 (file)
@@ -24,7 +24,8 @@ SRCREV  = "${AUTOREV}"
 # PV needs to be modified with SRCPV to work AUTOREV correctly
 PV = "0.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http \
+           file://homescreen.pc.in "
 
 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
@@ -47,8 +48,11 @@ do_install() {
 # error at build time:
 # ERROR: homescreen-git-r0 do_populate_sysroot: QA Issue: homescreen.pc failed sanity test (tmpdir) in path /xdt/build/tmp/work/cortexa15hf-neon-agl-linux-gnueabi/homescreen/git-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig]
 #
-#    install -d ${D}${libdir}/pkgconfig
-#    install -m 0644 ${B}/libhomescreen/pkgconfig/homescreen.pc ${D}${libdir}/pkgconfig/
+    install -d ${D}${libdir}/pkgconfig
+    install -m 0644 ${WORKDIR}/homescreen.pc.in ${D}${libdir}/pkgconfig/homescreen.pc
+    sed -i s:OEPREFIX:${prefix}:g ${D}${libdir}/pkgconfig/homescreen.pc
+    sed -i s:OELIBDIR:${libdir}:g ${D}${libdir}/pkgconfig/homescreen.pc
+    sed -i s:OEINCDIR:${includedir}:g ${D}${libdir}/pkgconfig/homescreen.pc
 
        install -d ${D}${includedir}
        install -m 0644 ${S}/libhomescreen/include/libhomescreen.hpp ${D}${includedir}/