Fixed an issue that libhomescreen can not be used 69/7569/1
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Tue, 13 Dec 2016 12:09:17 +0000 (21:09 +0900)
committerNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Tue, 13 Dec 2016 12:14:45 +0000 (21:14 +0900)
libhomescreen symbolic link is incorrect in Homescreen recipe.
This means that you can not build the application.
Fixing this problem will allow you to build the application.

Change-Id: Ifa6439a485db0205be5062d35791ce836fa832eb
Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
recipes-demo-hmi/homescreen/homescreen_git.bb

index a30b235..7bef3a2 100644 (file)
@@ -39,9 +39,9 @@ do_install() {
     
     install -d ${D}${libdir}
     install -m 0644 ${B}/libhomescreen/libhomescreen.so.1.0.0 ${D}${libdir}/
-    ln -sf ${libdir}/libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so
-    ln -sf ${libdir}/libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1
-    ln -sf ${libdir}/libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
+    ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so
+    ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1
+    ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
 
 # kooltux: still some problem with paths inside .pc file
 # error at build time: