settings: add service bindings to RDEPENDS 89/9989/1
authorMatt Ranostay <matt.ranostay@konsulko.com>
Fri, 30 Jun 2017 20:48:17 +0000 (23:48 +0300)
committerMatt Ranostay <matt.ranostay@konsulko.com>
Fri, 30 Jun 2017 20:48:26 +0000 (23:48 +0300)
Add bluetooth and wifi services to the settings package RDEPENDS

Bug-AGL: SPEC-661 SPEC-715
Change-Id: I4cf3cd14cabda38a32ca8fe4da97b8e747f9a1d9
Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
recipes-demo-hmi/settings/settings_git.bb

index a018c06..a1d26d7 100644 (file)
@@ -15,4 +15,9 @@ S  = "${WORKDIR}/git"
 # build-time dependencies
 DEPENDS += "qtquickcontrols2"
 
+# runtime dependencies
+RDEPENDS_${PN} += " \
+            agl-service-bluetooth \
+            agl-service-wifi"
+
 inherit qmake5 aglwgt