settings: add service bindings to RDEPENDS
[AGL/meta-agl-demo.git] / recipes-demo-hmi / settings / settings_git.bb
1 SUMMARY     = "Settings for CES2017 AGL Demonstration"
2 DESCRIPTION = "AGL HMI Application for demonstrating Settings on AGL Distribution"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/settings"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings;protocol=http"
10 SRCREV  = "${AUTOREV}"
11
12 PV = "1.0+git${SRCPV}"
13 S  = "${WORKDIR}/git"
14
15 # build-time dependencies
16 DEPENDS += "qtquickcontrols2"
17
18 # runtime dependencies
19 RDEPENDS_${PN} += " \
20             agl-service-bluetooth \
21             agl-service-wifi"
22
23 inherit qmake5 aglwgt