recipes-demo: restore launcher application 41/26941/5
authorArnaud Ferraris <arnaud.ferraris@collabora.com>
Tue, 7 Dec 2021 18:15:58 +0000 (19:15 +0100)
committerArnaud Ferraris <arnaud.ferraris@collabora.com>
Tue, 21 Dec 2021 08:02:51 +0000 (09:02 +0100)
While launcher hasn't been merged into homescreen, we should restore it
as a default application.

Bug-AGL: SPEC-4159
Signed-off-by: Arnaud Ferraris <arnaud.ferraris@collabora.com>
Change-Id: I772142beec717b0f244b1c1a9c128baf843827fd

recipes-demo/launcher/files/launcher.service [new file with mode: 0644]
recipes-demo/launcher/launcher_git.bb [new file with mode: 0644]

diff --git a/recipes-demo/launcher/files/launcher.service b/recipes-demo/launcher/files/launcher.service
new file mode 100644 (file)
index 0000000..6170f60
--- /dev/null
@@ -0,0 +1,12 @@
+[Unit]
+Name=AGL Launcher
+Requires=homescreen.service
+After=homescreen.service
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/launcher
+Restart=on-failure
+
+[Install]
+WantedBy=agl-session.target
diff --git a/recipes-demo/launcher/launcher_git.bb b/recipes-demo/launcher/launcher_git.bb
new file mode 100644 (file)
index 0000000..e677341
--- /dev/null
@@ -0,0 +1,47 @@
+SUMMARY     = "AGL Launcher Application"
+DESCRIPTION = "AGL Launcher Application build with recipe method"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/apps/launcher"
+SECTION     = "apps"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = "\
+        qtbase \
+        qtdeclarative \
+        qtquickcontrols2 \
+        qtwebsockets \
+        wayland-native \
+        wayland \
+        qtwayland \
+        qtwayland-native \
+        agl-compositor \
+        json-c \
+        applaunchd \
+"
+
+PV      = "1.0+git${SRCPV}"
+
+SRC_URI = " \
+        git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH} \
+        file://launcher.service \
+        "
+SRCREV  = "${AGL_APP_REVISION}"
+
+S       = "${WORKDIR}/git"
+
+inherit qmake5 systemd pkgconfig
+
+PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+
+do_install:append() {
+    install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
+    install -m0644 ${WORKDIR}/launcher.service ${D}${systemd_user_unitdir}/launcher.service
+    ln -s ../launcher.service ${D}${systemd_user_unitdir}/agl-session.target.wants/launcher.service
+}
+
+FILES:${PN} += " ${systemd_user_unitdir}"
+
+RDEPENDS:${PN} += " \
+    applaunchd \
+    homescreen \
+"