homescreen: convert to using the new App FW 77/26977/4
authorArnaud Ferraris <arnaud.ferraris@collabora.com>
Tue, 7 Dec 2021 18:15:56 +0000 (19:15 +0100)
committerArnaud Ferraris <arnaud.ferraris@collabora.com>
Tue, 21 Dec 2021 08:02:51 +0000 (09:02 +0100)
Bug-AGL: SPEC-4161
Signed-off-by: Arnaud Ferraris <arnaud.ferraris@collabora.com>
Change-Id: I3f53c4d9143baad15fee59110f5f9fbf64290d6c

recipes-demo/homescreen/files/homescreen.service
recipes-demo/homescreen/homescreen_git.bb

index 6d57ea7..b95d583 100644 (file)
@@ -1,14 +1,11 @@
 [Unit]
-Requires=weston.service
-After=weston.service
+Requires=agl-compositor.service
+After=agl-compositor.service
 
 [Service]
-# Placeholder configuration to run as weston user for now.
-User=weston
-Group=weston
-Environment=XDG_RUNTIME_DIR=/run/user/200
-EnvironmentFile=-/etc/default/homescreen
+Type=simple
 ExecStart=/usr/bin/homescreen
+Restart=on-failure
 
 [Install]
-WantedBy=graphical.target
+WantedBy=agl-session.target
index 2b183d5..f04305f 100644 (file)
@@ -14,6 +14,7 @@ DEPENDS = " \
     qtwayland \
     qtwayland-native \
     agl-compositor \
+    applaunchd \
 "
 
 PV = "1.0+git${SRCPV}"
@@ -32,13 +33,15 @@ PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
 
 do_install:append() {
-    install -D -p -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
+    install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
+    install -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
+    ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
 }
 
-SYSTEMD_SERVICE_${PN} = "homescreen.service"
-SYSTEMD_AUTO_ENABLE = "enable"
+FILES:${PN} += " ${systemd_user_unitdir}"
 
 RDEPENDS:${PN} += " \
+    applaunchd \
     qtwayland \
     qtbase-qmlplugins \
     qtgraphicaleffects-qmlplugins \