alexa-viewer: add recipe and conditionally add to demo image 01/23601/1
authorScott Murray <scott.murray@konsulko.com>
Mon, 20 Jan 2020 22:58:48 +0000 (17:58 -0500)
committerScott Murray <scott.murray@konsulko.com>
Mon, 20 Jan 2020 22:55:55 +0000 (22:55 +0000)
Add recipe for demo voice capabilities GUI metadata event viewer for
Alexa voiceagent, and conditionally add it to the list of applications
in packagegroup-agl-demo-platform based on the agl-voiceagent-alexa
feature being present in IMAGE_FEATURES.

Bug-AGL: SPEC-3110

Change-Id: I7b84ace51430937dbcb35f4773b06290039a19bd
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb

diff --git a/recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb b/recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb
new file mode 100644 (file)
index 0000000..f98704e
--- /dev/null
@@ -0,0 +1,33 @@
+SUMMARY     = "Demo voice capabilities template viewer for Alexa voiceagent"
+DESCRIPTION = "Demo voice capabilities template viewer for Alexa voiceagent"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/alexa-viewer"
+SECTION     = "apps"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = " \
+       qtquickcontrols2 \
+       qlibwindowmanager \
+       qlibhomescreen \
+       af-binder \
+       libqtappfw \
+"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/alexa-viewer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S  = "${WORKDIR}/git"
+
+inherit cmake_qt5 aglwgt
+
+OECMAKE_CXX_FLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+
+RDEPENDS_${PN} = " \
+       libqtappfw \
+       libafbwsc \
+       qlibwindowmanager \
+       qlibhomescreen \
+       agl-service-voice-high-capabilities \
+"
index 80ad559..8fa7e6e 100644 (file)
@@ -37,6 +37,7 @@ AGL_APPS = " \
     agl-service-signal-composer \
     low-can-demo \
     virtual/mixer \
     agl-service-signal-composer \
     low-can-demo \
     virtual/mixer \
+    ${@bb.utils.contains('IMAGE_FEATURES', 'agl-voiceagent-alexa', 'alexa-viewer' , '', d)} \
     "
 
 QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"
     "
 
 QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"