alexa-viewer: add recipe and conditionally add to demo image
[AGL/meta-agl-demo.git] / recipes-demo-hmi / alexa-viewer / alexa-viewer_git.bb
1 SUMMARY     = "Demo voice capabilities template viewer for Alexa voiceagent"
2 DESCRIPTION = "Demo voice capabilities template viewer for Alexa voiceagent"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/alexa-viewer"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = " \
10         qtquickcontrols2 \
11         qlibwindowmanager \
12         qlibhomescreen \
13         af-binder \
14         libqtappfw \
15 "
16
17 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/alexa-viewer;protocol=https;branch=${AGL_BRANCH}"
18 SRCREV  = "${AGL_APP_REVISION}"
19
20 PV = "1.0+git${SRCPV}"
21 S  = "${WORKDIR}/git"
22
23 inherit cmake_qt5 aglwgt
24
25 OECMAKE_CXX_FLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
26
27 RDEPENDS_${PN} = " \
28         libqtappfw \
29         libafbwsc \
30         qlibwindowmanager \
31         qlibhomescreen \
32         agl-service-voice-high-capabilities \
33 "