poiapp: Add patch to add display permission 52/21752/1
authorScott Murray <scott.murray@konsulko.com>
Wed, 26 Jun 2019 18:30:13 +0000 (14:30 -0400)
committerScott Murray <scott.murray@konsulko.com>
Wed, 26 Jun 2019 18:30:13 +0000 (14:30 -0400)
Add a patch to the poiapp's config.xml to add the new display
permission.  A patch is used for timeliness, it can be removed if/when
the change goes into the upstream repo.

Bug-AGL: SPEC-2559

Change-Id: Ibd52cb93847b2b7df9988ad276ebd8cbfc80900b
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/navigation/poiapp/0001-add-display-permission.patch [new file with mode: 0644]
recipes-demo-hmi/navigation/poiapp_git.bb [changed mode: 0755->0644]

diff --git a/recipes-demo-hmi/navigation/poiapp/0001-add-display-permission.patch b/recipes-demo-hmi/navigation/poiapp/0001-add-display-permission.patch
new file mode 100644 (file)
index 0000000..25a8fc3
--- /dev/null
@@ -0,0 +1,21 @@
+Add display permission
+
+Add display permission required to work with the running as non-root
+change for applications.
+
+Upstream-Status: pending
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+diff --git a/config.xml.in b/config.xml.in
+index b8cfccd..bec206d 100755
+--- a/config.xml.in
++++ b/config.xml.in
+@@ -13,6 +13,7 @@
+   <feature name="urn:AGL:widget:required-permission">
+     <param name="urn:AGL:permission::public:no-htdocs" value="required" />
+     <param name="http://tizen.org/privilege/internal/dbus" value="required" />
++    <param name="urn:AGL:permission::public:display" value="required" />
+   </feature>
+   <license>GPL</license>
+ </widget>
old mode 100755 (executable)
new mode 100644 (file)
index a17979b..9c9292b
@@ -18,6 +18,7 @@ RDEPENDS_${PN} =  " qtbase \
 
 SRCREV = "c2691cb265d9198542482a860f1df378e8c2708b"
 SRC_URI = "git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=agl \
+           file://0001-add-display-permission.patch \
           "
 
 S = "${WORKDIR}/git"